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Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programmi
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evi
by receipts or other documentation.  National Instruments will, at its option, repair or replace software media t
not execute programming instructions if National Instruments receives notice of such defects during the warra
period.  National Instruments does not warrant that the operation of the software shall be uninterrupted or erro

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the ou
of the package before any equipment will be accepted for warranty work.  National Instruments will pay the shi
costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate.  The document has been careful
reviewed for technical accuracy.  In the event that technical or typographical errors exist, National Instruments re
the right to make changes to subsequent editions of this document without prior notice to holders of this edition
reader should consult National Instruments if errors are suspected.  In no event shall National Instruments be lia
any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND 
SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE.  
CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  
INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER.  NATIONAL  INSTRUMENTS 
WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.  This limitation of the liability of National 
Instruments will apply regardless of the form of action, whether in contract or tort, including negligence.  Any a
against National Instruments must be brought within one year after the cause of action accrues.  National Instr
shall not be liable for any delay in performance due to causes beyond its reasonable control.  The warranty pr
herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow t
National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; 
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third par
other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mecha
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part
without the prior written consent of National Instruments Corporation.

Trademarks

LabVIEW®, NI-DAQ®, BridgeVIEW™, National Instruments™, and natinst.com™ are trademarks of National 
Instruments Corporation.

Product and company names listed are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing intended to ensure a level of reli
suitable for use in treatment and diagnosis of humans.  Applications of National Instruments products involving
medical or clinical treatment can create a potential for accidental injury caused by product failure, or by errors 
part of the user or application designer.  Any use or application of National Instruments products for or involvin
medical or clinical treatment must be performed by properly trained and qualified medical personnel, and all trad
medical safeguards, equipment, and procedures that are appropriate in the particular situation to prevent seriou
or death should always continue to be used when National Instruments products are being used.  National Instr
products are NOT intended to be a substitute for any form of established process, procedure, or equipment us
monitor or safeguard human health and safety in medical or clinical treatment.
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The BridgeVIEW Run-Time System Guide contains the information you 
need to get started with the BridgeVIEW Run-Time System softwar
package. This manual explains the BridgeVIEW environment, tag 
configuration, alarms and events, and historical data logging and 
extraction.

This manual presumes that you know how to operate your computer
that you are familiar with its operating system. 

Organization of This Manual

• Chapter 1, Introduction, describes the unique BridgeVIEW 
approach to Supervisory Control and Data Acquisition (SCADA
It also contains system configuration, installation instructions a
basic information that explains how to use BridgeVIEW. This 
chapter refers you to other chapters or manuals for more 
information.

• Chapter 2, BridgeVIEW Environment, describes the BridgeVIEW 
environment. It explains the BridgeVIEW Engine Manager, syste
errors and events, the Tag Monitor utility, and the Tag Browser
utility. This chapter also explains how to access online help for
BridgeVIEW.

• Chapter 3, Tag Configuration, explains tags, the Tag Configuration
Editor, and how you edit tags within the BridgeVIEW system. 
Before you can run a BridgeVIEW application, you must specify
tag configuration.

• Chapter 4, Alarms and Events, introduces the basic concepts of 
alarms and events, and explains how to view, acknowledge, an
configure them within the BridgeVIEW system. 

• Chapter 5, Historical Data Logging and Extraction, explains the 
concept of a trend, how to log and extract historical data, and h
to use the Historical Trend Viewer (HTV), a utility that displays 
historical data that has been logged to disk with BridgeVIEW.
Time System Guide
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• Chapter 6, BridgeVIEW Security, explains BridgeVIEW Environment 
Security.

• Chapter 7, Industrial Automation Device Servers, explains Industrial 
Automation (IA) device servers, how to install and configure a 
device server, and how to view that configuration within 
BridgeVIEW. This chapter also describes how to use DDE serv
with BridgeVIEW and how you can develop your own device 
servers.

• Appendix A, Citadel and Open Database Connectivity, describes the 
Citadel database and the Open Database Connectivity (ODBC)
driver, and includes a table that lists data transform commands

• Appendix B, Customer Communication, contains forms to help you 
gather the information necessary to help us solve your technica
problems and a form you can use to comment on the product 
documentation.

• The Glossary contains an alphabetical list of terms used in this 
manual, including abbreviations, acronyms, metric prefixes, 
mnemonics, and symbols.

• The Index contains an alphabetical list of key terms and topics i
this manual, including the page where you can find each one.

Conventions Used in This Manual
The following conventions are used in this manual:

bold Bold text denotes a parameter, menu name, palette name, menu it
return value, function panel item, or dialog box button or option.

italic Italic text denotes mathematical variables, emphasis, a cross refere
or an introduction to a key concept.

bold italic Bold italic text denotes an activity objective, note, caution, or warnin

monospace Text in this font denotes text or characters that you should literally en
from the keyboard. Sections of code, programming examples, and 
syntax examples also appear in this font. This font also is used for 
proper names of disk drives, paths, directories, programs, subprogra
subroutines, device names, variables, filenames, and extensions, an
statements and comments taken from program code.

<> Angle brackets enclose the name of a key on the keyboard—for 
example, <PageDown>.
BridgeVIEW Run-Time System Guide xii © National Instruments Corporation
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- A hyphen between two or more key names enclosed in angle brack
denotes that you should simultaneously press the named keys—fo
example, <Control-Alt-Delete>.

<Control> Key names are capitalized.

» The » symbol leads you through nested menu items and dialog box
options to a final action. The sequence 
File»Page Setup»Options»Substitute Fonts directs you to pull down 
the File menu, select the Page Setup item, select Options, and finally 
select the Substitute Fonts option from the last dialog box.

paths Paths in this manual are denoted using backslashes (\) to separate 
names, directories, and files, as in 
C:\dir1name\dir2name\filenam e.

This icon to the left of bold italicized text denotes a note, which ale
you to important information.

Abbreviations, acronyms, metric prefixes, mnemonics, symbols, an
terms are listed in the Glossary.

Related Documentation
The following document contains information that you might find 
helpful as you read this manual:

• BridgeVIEW Run-Time System Online Reference, available online 
by selecting Help»Online Reference

Customer Communication
National Instruments wants to receive your comments on our produ
and manuals. We are interested in the applications you develop with
products, and we want to help if you have problems with them. To m
it easy for you to contact us, this manual contains comment and 
configuration forms for you to complete. These forms are in Appendix B,
Customer Communication, at the end of this manual.
© National Instruments Corporation xiii BridgeVIEW Run-Time System Guide
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This chapter describes the unique BridgeVIEW approach to 
Supervisory Control and Data Acquisition (SCADA). It also contain
system configuration, installation instructions and basic information
that explains how to use BridgeVIEW. This chapter refers you to oth
chapters or manuals for more information.

Welcome To BridgeVIEW
The BridgeVIEW Run-Time System provides an environment to run
Man Machine Interface (MMI) and SCADA applications developed 
the BridgeVIEW Development System.

Required System Configuration
The BridgeVIEW Run-Time System is distributed on a CD-ROM tha
includes the complete BridgeVIEW Run-Time System 1.0 release.

The Windows 95/NT version of the BridgeVIEW Run-Time System 
runs on any system that supports Windows 95 or Windows NT 3.51
later. You should have a minimum of 24 MB of RAM for this version
to run effectively. We recommend 32 MB of RAM and at least 30 M
of swap space available on your system.

Note: The standard BridgeVIEW Run-Time System installation requires 
approximately 30 to 45 MB of disk space. If you plan to install the NI-DAQ
Server as well, you will need an additional 30 MB.

Installation
1. Insert the CD in your CD-ROM drive.   

2. Run the BridgeVIEW Run-Time System installer. 

a. If you have Windows 95 or Windows NT 4.0 and your syste
uses the AutoPlay feature, the Welcome to BridgeVIEW scre
appears a short time after you insert the CD.
Time System Guide
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b. If you have Windows NT 3.51 or a system not using AutoPla
run the following program:
X:\bvsetup.exe  
where X is the letter of your CD-ROM drive.

3. Choose an installation. The installer offers several installation 
types: Standard, Full, Minimum, and Custom. The Standard 
installation requires approximately 30 to 45 MB. 

Note: Consult the documentation that came with your application software or 
check with your system developer to determine which type of installation
choose. See the Where Should I Start? section later in this chapter for more 
information on the different installation types. 

4. After selecting an installation, follow the instructions that appea
on your screen.

What Is BridgeVIEW?
BridgeVIEW is a software package specifically targeted at industria
automation applications. BridgeVIEW provides configurable solutio
for common MMI and SCADA functions while leveraging the 
flexibility of graphical programming. BridgeVIEW is built around the
G programming language, created by National Instruments 
Corporation.

With BridgeVIEW, you can acquire data and control one or more 
distributed devices in an overall facility. BridgeVIEW can change s
points or send control instructions to the individual devices while 
monitoring the entire system. It also can gather information like alar
and measurement points from these devices.

Common devices used for data acquisition include Progammable Lo
Controllers (PLCs), plug-in Data Acquisition boards, and other 
distributed Input/Output (I/O) modules. BridgeVIEW device servers
communicate with these non-plug-in devices through RS-232, RS-4
TCP/IP, DDE, netDDE, direct I/O, or other proprietary interfaces. 
BridgeVIEW device servers provide the necessary protocol software
communicate with these devices.

The BridgeVIEW Run-Time System is an execution environment fo
applications (also referred to here as application software) created u
the BridgeVIEW Development System. With the Run-Time System,
you cannot edit the Virtual Instruments (VIs) used to create the MMI
BridgeVIEW Run-Time System Guide 1-2 © National Instruments Corporation
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an application. Your application software consists of a set of VIs for 
MMI and supporting functionality of the software, the definition of a
data points in the system (tags), and the configuration of the servers
provide data to BridgeVIEW and your application.

This guide does not address the specific nature of the application 
software executed in the BridgeVIEW Run-Time System. Instead, i
describes the features of BridgeVIEW, its architecture, execution 
system, and configuration tools. The creator of your application 
software (referred to here as the developer) might provide addition
documentation for the application software. You should consult the
application developer for specific questions about your application 
software.

How Does BridgeVIEW Work? 
BridgeVIEW uses a combination of tags, events, and data. A tag is a 
connection to a real-world I/O point, while an event is anything that 
happens to a tag or to the BridgeVIEW Engine in general. The 
BridgeVIEW Engine communicates with device servers on one end, 
with your MMI application at the other end. The BridgeVIEW Engin
maintains a Real-Time Database (RTDB) of tag information and log
historical data and events. 

Start by configuring all the tags in your system with the Tag 
Configuration Editor. Then, you can launch the BridgeVIEW Engine
which reads your configuration file and starts monitoring tags, loggi
data and events. You also can acknowledge alarms and control ou
tags. For more information about how to get started with the 
BridgeVIEW Run-Time System, see the Where Should I Start? section 
at the end of this chapter. 

Tag Configuration
A tag value is acquired and/or controlled by a device server that 
communicates with the BridgeVIEW Engine. Tags can be of the 
following types: input, output, Input/Output, or memory. You can 
configure tags through the Tag Configuration Editor. A tag 
configuration consists of its data type, connection, scaling, operatio
and alarms settings. For more information about this topic, refer to
Chapter 3, Tag Configuration. 
© National Instruments Corporation 1-3 BridgeVIEW Run-Time System Guide
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Data Type 
A tag data type can be analog, discrete, bit array, or string. Analog ta
have continuous values with a specified range (such as 0.0 to 100.
Discrete tags have values that are either ON (1) or OFF (0). Bit arr
tags are comprised of up to 32 bits, each of which can have an ON
or OFF (0) state. String tags consist of ASCII characters or binary d
and can be of any length.

Connection
Connection includes the following tag attributes: 

• Name

• Description

• Group

• Access rights (input only, output only, Input/Output, or memory

• Server name

• Device name

• Item name

• Length (for bit array and string tags)

Scaling
Scaling controls the type of scaling to perform on a tag when 
communicating with a device server, and the expected engineering
range and units for the tag.

Operations
You can specify how the BridgeVIEW Engine updates the Real-Time 
Database (RTDB), when it will log the tag data to disk, if it will log 
events associated with the tag, and what value exists in the databa
startup. The operations that can be performed on a tag are as follows

• Updating the Real-Time Database 

• Historical logging 

• Event logging 

• Event printing
BridgeVIEW Run-Time System Guide 1-4 © National Instruments Corporation
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Alarms
An alarm is an abnormal process condition. For example, an analog
can be configured to be in a HI alarm state when its value is greater 
25. You can set alarm limits for a tag in the Tag Configuration Edito
Each alarm limit has a priority associated with it to determine the 
severity of the alarm.

Events
An event is something that happens within the BridgeVIEW system
Events can be divided into two groups, those that pertain to individ
tags and those that pertain to the overall BridgeVIEW system. Eve
pertaining to tags include the following:

• A tag going in or out of alarm

• An operator changing the value of a tag

• An operator acknowledging an alarm

Events pertaining to the system include the following: 

• The launching or shutting down of the Engine

• A new operator logging on

• An error from a server

The Engine also maintains alarm summary and event history 
information pertaining to tags. This information can be viewed by yo
MMI and/or be logged to disk.

Historical Data Logging and Extraction
You can extract data from the historical database to view the trend
tag data over time. The BridgeVIEW Engine manages logging data
the Citadel Historical Database. A trend is a view of data over time. 
Trends can be real-time (current data) or historical (logged data). Y
can view logged data with a user interface (MMI) or with the Historic
Trend Viewer (HTV). For more information about historical data 
logging and extraction or the Citadel Historical Database, see Chapter 5, 
Historical Data Logging and Extraction, or Appendix A, Citadel and 
Open DatabaseConnectivity. 
© National Instruments Corporation 1-5 BridgeVIEW Run-Time System Guide
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Environment security is built into BridgeVIEW and determines acce
to certain parts of the BridgeVIEW environment. BridgeVIEW securi
is broken into two general categories: 

• BridgeVIEW Environment Access Privileges

• Operator Interface Security

What Is the BridgeVIEW System Architecture?
The BridgeVIEW system contains three sets of processes: the user M
Application, the BridgeVIEW Engine, and industrial automation devi
servers, as shown in Figure 1-1, BridgeVIEW Architecture. These 
processes interact through a client-server relationship.

Figure 1-1.  BridgeVIEW Architecture

The BridgeVIEW Engine, with any device servers, runs as a separate
process independent of your MMI application. Your MMI application is
built as a collection of VIs developed using the G programming langua

• EU Scaling

PLC DAQ DDE Other

Real-Time Database

MMIs

Tags

Servers

VIs

BridgeVIEW
Engine

• Trending

• Event/Alarm Logging

• Alarming
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BridgeVIEW maintains a high performance Real-Time Database in 
BridgeVIEW Engine that provides information to client applications
The BridgeVIEW Engine also performs other functions including th
following:

• Data acquisition, engineering unit (EU) scaling, and alarm 
processing

• Alarm and event logging

• Historical data collection and trending

EU scaling converts the Raw Range value from the device server to
engineering value used in the user application and vice versa. 

BridgeVIEW Engine
The BridgeVIEW Engine is the heart of the BridgeVIEW System. This
minimizes interference between the Engine and your MMI. The 
BridgeVIEW Engine maintains the Real-Time Database of all tag 
values and alarm states. It reads values from the various device ser
These values are scaled and compared with their alarm limits. If a ta
in an alarm state, the Engine generates appropriate events and logs
to disk.

The Real-Time Database (RTDB) is an in-memory snapshot of the s
of all tags in the system. If a tag value changes more than its upda
deadband, or its alarm state changes, the RTDB is updated. Along 
tag values, the RTDB also stores status, date, time, and alarm 
information. 

Industrial Automation Device Servers
A device server is the application that communicates with the I/O 
devices such as PLCs and plug-in cards. All device servers are wri
to a standard client/server Application Programming Interface (API) 
the BridgeVIEW Engine. There are different servers for different 
device manufacturers and communication networks.

The device servers that support the BridgeVIEW Engine are 
stand-alone programs launched by the BridgeVIEW Engine, and 
thereafter run in the background, reading selected input items and 
writing them on demand. Each server has a specific configuration uti
that determines communication parameters, I/O poll rates, and dev
addresses. A server completes operation only when the BridgeVIE
Engine shuts down. 
© National Instruments Corporation 1-7 BridgeVIEW Run-Time System Guide
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Input items are polled at a rate determined by the server configurat
For each input item, the device server passes the value, the timest
of when the item was sampled, and status information to the 
BridgeVIEW Engine. Output items are written on demand only, for 
example, when the BridgeVIEW Engine passes a new output value

The device server monitors the items and encapsulates all device-
hardware-specific details, thereby providing a hardware- and softw
independent layer to the user MMI and SCADA application. For mo
information about device servers, see Chapter 7, Industrial Automation 
Device Servers.

Where Should I Start?

Install the BridgeVIEW Run-Time System 
See the Installation section at the beginning of this chapter for more 
information on installation. The following table lists what is included 
the different installation types.

Note: The Launch Engine, Login, Logout, Change Password, and Edit User 
Accounts utilities are always installed.

Installation 
Type Includes

Minimum Tag Configuration Editor, basic security tools, 
core VI libraries

Standard Tag Configuration Editor, all security tools, 
Historical Trend Viewer, Tag Browser, 
Tag Monitor, core VI libraries, advanced analysis
libraries

Full Tag Configuration Editor, all security tools, 
Historical Trend Viewer, Tag Browser, 
Tag Monitor, core VI libraries, advanced analysis
libraries, DAQ, GPIB, and VISA libraries

Custom You can select which  utilities and libraries to 
install.
BridgeVIEW Run-Time System Guide 1-8 © National Instruments Corporation
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In addition, you might need to install additional drivers for use with
your application software You will be prompted to install additional 
driver software during the BridgeVIEW Run-Time System setup. Yo
might also need to install additional data servers for your applicatio
software. Consult the documentation for your application software.

Install the Application Software
Follow the instructions provided by the system developer for installi
the application software. After installing the files, note the location 
the .scf and .ccdb  files.

Install the Required Servers
If your application software uses the NI-DAQ Server for BridgeVIEW
install the NI-DAQ Server from the BridgeVIEW Run-Time System 
CD. Other servers must be installed separately.

Update Preference Files
Consult the documentation for your application software to ensure t
any specific preference files for the application are placed in the corr
locations. These files contain non-default settings for BridgeVIEW 
utilities such as htv.ini . You can edit these files with a simple text 
editor such as Notepad. Specific instructions about these preferenc
files should be included with your application software.

Finish Server Setup
For National Instruments Device Servers, you might need to resolve
paths to the servers stored in the .ccdb  file. Use the Server Explorer to
do this. The Server Explorer is installed when you install servers fro
the National Instruments Device Servers CD. Start the Server Explo
select File»Open… and locate the .ccdb  file for your application 
software. After this, choose File»Set this file as Active CCDB.

VI-based servers (if used by your application) will provide their own
Server Registration VIs, as described in your application software 
documentation. 

Configure BridgeVIEW Startup 
Launch the BridgeVIEW Run-Time System. The first time you run i
you might be prompted to configure one or more startup VIs, as sho
in the illustration below. These startup VIs are the user interface pan
© National Instruments Corporation 1-9 BridgeVIEW Run-Time System Guide
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that appear when you launch the BridgeVIEW Run-Time System. U
the Configure BridgeVIEW Startup dialog box to locate the appropria
startup VIs, as identified in your application software documentation
you do not define at least one startup VI, you will be prompted to eit
configure the startup VIs or exit the application. 

If your application starts the engine when it launches, and the serv
have not been registered properly, you will receive error messages
identifying the servers that could not be started. Consult your 
application software documentation for more information about whi
servers it requires, and how to register them. 
BridgeVIEW Run-Time System Guide 1-10 © National Instruments Corporation
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This chapter describes the BridgeVIEW environment. It explains th
BridgeVIEW Engine Manager, system errors and events, the Tag 
Monitor utility, and the Tag Browser utility. This chapter also explain
how to access online help for BridgeVIEW.

BridgeVIEW Environment Project Menu
Note: Your application software might not provide access to the Project menu. If 

you require access to this menu, contact the application developer.

The BridgeVIEW system is comprised of a collection of software too
designed specifically for industrial automation applications. You ca
access these tools through the Project menu in your BridgeVIEW 
system. Table 2-1, BridgeVIEW Project Menu Items, provides a brief 
description of the items in the Project menu.

Table 2-1.     BridgeVIEW Project Menu Items

Project Menu Item Description

Historical Trend Viewer Launches the Historical Trend Viewer (HTV).  You can use the
HTV to view historical data that has been logged in the Citadel
Historical Database.  For more information about the HTV, see
Chapter 5, Historical Data Logging and Extraction. 

Launch Engine Launches the BridgeVIEW Engine. The BridgeVIEW Engine 
manages the Real-Time Database, communicates with device
servers, and performs alarm management and historical data 
logging. The BridgeVIEW Engine runs according to a 
configuration file called a .scf  (SCADA Configuration File) file. 
You can create and edit .scf  files using the Tag Configuration 
Editor. For more information about the BridgeVIEW Engine, se
the section What Is the BridgeVIEW Engine Manager? in this 
chapter.
Time System Guide
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Security»Access Levels Opens a utility you can use to add, remove, and modify access
levels in your BridgeVIEW system.  If user accounts are define
in your system, you must have Administration privileges to edit
the list of access levels.  For more information about security a
access levels, see Chapter 6, BridgeVIEW Security.

Security»Change Password Opens a dialog box to change the current user’s password.  Yo
must be logged in to change your password. For more informat
about security and passwords, see Chapter 6, BridgeVIEW 
Security.

Security»Edit User Accounts Opens a utility you can use to create and edit user accounts in y
BridgeVIEW system. If user accounts are defined in your syste
you must have Administration privileges to create and edit use
accounts.  For more information about security and user accou
see Chapter 6, BridgeVIEW Security.

Security»Login Opens a dialog box you can use to log in to the system. For m
information about security, see Chapter 6, BridgeVIEW Security.

Security»Logout Opens a dialog box you can use to log out of the system. For m
information about security, see Chapter 6, BridgeVIEW Security.

Security»Privileges Opens a utility you can use to view your access privileges.  Fo
more information about security and access levels, see Chapter 6, 
BridgeVIEW Security.

Server Tools»Server BrowserLaunches the Server Browser.  You can use the Server Browse
view information about the servers registered with BridgeVIEW
For more information about the Server Browser, see Chapter 7, 
Industrial Automation Device Servers.

Tag»Browser Launches the Tag Browser.  You can use the Tag Browser to vi
information on all of the tags in the currently-loaded .scf  file.  If 
the BridgeVIEW Engine is not running, you can use the Tag 
Browser to load a different .scf  file.  For more information about 
the Tag Browser, see the section What Is the Tag Browser? in this 
chapter.

Table 2-1.     BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
BridgeVIEW Run-Time System Guide 2-2 © National Instruments Corporation
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What Is the BridgeVIEW Engine Manager?
When you run any G application that accesses the BridgeVIEW 
Real-Time Database, the BridgeVIEW Engine launches automatica
opening either the tag configuration (.scf ) file that you edited most 
recently or the one that your application has selected programmatica

Launching the BridgeVIEW Engine brings up the Engine Manager 
Display, shown in Figure 2-1. The Engine Manager is a window into the
BridgeVIEW Engine, through which you can control some of the 
behavior of the BridgeVIEW Engine.

Figure 2-1.  Engine Manager Display

Table 2-2, Engine Manager Field Descriptions, provides a description of 
each of the fields in the Engine Manager dialog box. This table provi
basic information about the Engine Manager dialog box options. Fo
more complete understanding of how or why you might use the Eng

Tag»Configuration Launches the Tag Configuration Editor. You can use the Tag 
Configuration Editor to define all of the tags in your BridgeVIEW
system. Also, you can configure other Engine parameters in th
Tag Configuration Editor. For more information about the Tag 
Configuration Editor, see Chapter 3, Tag Configuration.

Tag»Monitor Launches the Tag Monitor. You can use the Tag Monitor to 
monitor the value, alarm state, and status of all tags in the syst
The Tag Monitor launches the BridgeVIEW Engine if it is not 
already running. For more information on the Tag Monitor, see t
section What Is the Tag Monitor? in this chapter.

Table 2-1.     BridgeVIEW Project Menu Items (Continued)

Project Menu Item Description
© National Instruments Corporation 2-3 BridgeVIEW Run-Time System Guide
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Manager in a BridgeVIEW application, you must understand how to
configure tags. See Chapter 3, Tag Configuration. 

Table 2-2.     Engine Manager Field Descriptions

Field Description

Engine Status Displays the current status of the BridgeVIEW Engine—whether launchin
running, or stopped. 

Log Historical 
Data 

Turns on or off logging of historical data to file. This button is pressed 
automatically if you selected Start logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, or 
not have a printer configured, this checkbox is disabled. 

Log Events Turns on or off logging of alarms and events to file. This button is presse
automatically if you selected Start event logging on system start-up in your 
configuration file. If you do not have a valid event log path configured, thi
checkbox is disabled.

Print Events Turns on or off printing of alarms and events to your line printer. This butt
is pressed automatically if you selected Start printing on system start-up in 
your configuration file. If you do not have a printer configured, this checkb
is disabled.

Run/Stop Engine Starts the BridgeVIEW Engine, or stops the BridgeVIEW Engine and shu
down any loaded servers. 

Quit Engine Closes and exits the BridgeVIEW Engine process. 

Enable Error 
Dialog

Enables or disables the showing of the Error dialog box. If this box is check
a System Error Display dialog box pops up for you to acknowledge the ev
when a system error occurs. 

Server Browser Launches the Server Browser Utility. With this utility, you can see the serv
in your system, view server registration information, and display the serv
front panel if the server is running. 

Show/Hide 
System Event 
Display 

Shows or hides the System Event Display.
BridgeVIEW Run-Time System Guide 2-4 © National Instruments Corporation
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The Engine Manager shows the current state of the Engine, and ha
System Event Display that shows the following: 

• BridgeVIEW System Events 

• When the Engine started and stopped 

• Which servers have been launched 

• Any System Errors that have occurred 

This information is written to the current BridgeVIEW System Log 
File, found in the BridgeVIEW\Syslog  folder. Figure 2-2 shows how 
the Engine Manager Display looks when the Show System Events 
Display button is enabled.

Figure 2-2.  Engine Manager with System Events Displayed

Once the BridgeVIEW Engine is launched and running, the Engine
Manager is minimized and appears in your Windows taskbar. Click
the BridgeVIEW Engine icon in your taskbar to bring up the Engine
Manager Display. 

You can leave the BridgeVIEW Engine Manager Display minimized
unless you need to start or stop the Engine, or start or stop historic
logging, event logging and printing, view system events, or view ser
information. 

From the Engine Manager, you can reach the Server Browser Utilit
shown below, by pressing the Server Browser… button. With this 
utility, you can see the servers in your system, view server registration
information, and display the server front panel if the server is running.
© National Instruments Corporation 2-5 BridgeVIEW Run-Time System Guide
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The Server Browser is shown in the following illustration. For more
information about device servers, see Chapter 7, Industrial Automation 
Device Servers.

The Show Server User Interface button appears on the Server Browse
dialog box only when you invoke the Server Browser from the Engi
Manager. 

If your application does not shut down within a few seconds after you 
close the BridgeVIEW Engine Manager, BridgeVIEW displays a dialo
box notifying you to shut down your MMI application. You can ensure th
your application shuts down when the Engine shuts down by monitorin
the shutdown output of any Tags or Alarms VI in your diagram.

What Are System Errors and Events?
System errors are conditions on a system level (as opposed to a per
basis) that result in problematic functioning of the BridgeVIEW syste
When a system error occurs, BridgeVIEW prompts the user with a 
dialog box. You can turn this dialog box on or off.

System events are changes in the system that cause a change in beha
that is not problematic. These include events reported by utilities s
as the Tag Configuration Editor.
BridgeVIEW Run-Time System Guide 2-6 © National Instruments Corporation
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Detailed system error and event messages are logged to a system
file. The messages are written to an ASCII file with a .log  extension in 
the SYSLOG directory. BridgeVIEW automatically creates this 
directory, if it does not exist already. The system log file names take
format, YYMMDDHHMM.log where YY = year, MM = month, DD = day, 
HH= hour, and MM = minute.

What Is the Tag Browser?
With the Tag Browser utility, shown in Figure 2-3, you can view the 
general configuration of all configured tags in the system. Launch t
Tag Browser by selecting Project»Tag»Browser. 

A list of all the configured tags appears in the listbox. Select a tag 
clicking on it, and the configuration for that tag displays on the righ
For more detailed tag configuration information or to learn how to e
a tag configuration, see Chapter 3, Tag Configuration.

Figure 2-3.  Tag Browser Utility
© National Instruments Corporation 2-7 BridgeVIEW Run-Time System Guide
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Table 2-3, Tag Browser Field Descriptions, describes each of the fields
in the Tag Browser Utility dialog box. 

Table 2-3.     Tag Browser Field Descriptions

Field Description

Configuration 
File

Displays the name of the configuration file that you are browsing.

Browse If the BridgeVIEW Engine is not running, press this button to select a differen
configuration file.

Location Displays the full path of the directory containing the configuration file that you a
browsing.

Engine Status Displays the current state of the BridgeVIEW Engine, whether it is loaded, 
running or stopped.

Configured 
Tags

Displays the list of all tags currently configured. Click on a tag to display the 
configuration on the right. 

Name Displays the name of the currently selected tag. Use this display to select and 
the tag name and paste it into your MMI diagram.

Description Displays the description field for the currently selected tag.

Type Displays the type of the currently selected tag: analog, discrete bit array, or st

Access Displays the access rights for the currently selected tag: Memory, Input, Out
or Input/Output.

Group Displays the group to which the selected tag belongs. If this field is blank, the
does not belong to a group.

Server Displays the name of the server that is connected to the currently selected ta
If the tag is a memory tag, no server is associated with it.

Device Displays the name of the device connected to the currently selected tag. If th
is a memory tag, no server or device is associated with it.

Item Displays the name of the item connected to the selected tag. If the tag is a me
tag, no server, device or item is associated with it.
BridgeVIEW Run-Time System Guide 2-8 © National Instruments Corporation
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If the BridgeVIEW Engine is loaded, you can view the tags currentl
loaded with the Tag Browser. If the BridgeVIEW Engine is not loade
the Tag Browser displays the currently loaded .scf  file. Use the 
Browse… button to change the .scf  file.

The Tag Browser is a useful tool to see how the tags in your system
configured. You can use the Tag Browser to change the loaded 
configuration file.

Alarms 
Enabled

Displays whether alarms are enabled for the selected tag. 

Auto Ack Displays whether alarms for the selected tag are acknowledged automaticall

Full Scale Displays the full scale engineering value for the tag. This is displayed for ana
tags only.

Zero Scale Displays the zero scale engineering value for the tag. This is displayed for an
tags only.

Units Displays the engineering unit for the tag. This is displayed for analog tags on

Table 2-3.     Tag Browser Field Descriptions (Continued)

Field Description
© National Instruments Corporation 2-9 BridgeVIEW Run-Time System Guide
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What Is the Tag Monitor?
With the Tag Monitor, you can monitor the value, unit, timestamp, 
alarm state, and status for selected tags in the system. You launch
Tag Monitor by selecting Project»Tag»Monitor. When you first launch 
the Tag Monitor, a tag selection dialog box displays all the tags 
configured in the currently selected tag configuration file. For more
information about configuring tags, refer to Chapter 3, Tag 
Configuration. Figure 2-4 shows the Tag Monitor. 

Figure 2-4.  Tag Monitor Utility

Note: Selecting the Tag Monitor from the Project menu automatically launche
the BridgeVIEW Engine if it is not running already.

Tag information is shown in a table format, sorted by tag name. Wh
a tag has a non-zero tag status, the Status column indicates if the 
status is Warning  or Error . 
BridgeVIEW Run-Time System Guide 2-10 © National Instruments Corporation
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Each of the fields and captions in the Tag Monitor Utility are describ
in Table 2-4, Tag Monitor Utility Field Descriptions. 

Table 2-4.     Tag Monitor Utility Field Descriptions

Field Descriptions

Tag Display Table Shows information for tags you have selected in alphabetical order. Thi
information includes the value, units, timestamp, status, alarm state and
error, if any. 

Trigger Tag Displays which tag, if any, you have selected to trigger refreshing of the T
Display Table. If you have selected a tag to trigger refreshing of the Tag
Display Table, the display refreshes when that tag changes value in the
database, or the monitor timeout period is exceeded, whichever occurs 

Monitor Timeout 
(secs)

Displays the time interval in seconds that the Tag Display Table is 
configured to refresh or update. If no trigger tag is selected, the display
updates at this time interval. Otherwise, the Tag Display Table refreshe
when the tag changes or the timeout interval is exceeded, whichever oc
first.

Status Details Brings up the Status Details dialog box, shown in Figure 2-5, that displays a 
summary of the status for each tag in the system. Tags that have a war
are highlighted in blue, and tags in error are red. BridgeVIEW provides 
description of the error or warning when possible. Internal codes are 
reported by BridgeVIEW; the Server Code is returned by the server of t
tag.

Select Tags to 
Monitor

Brings up the Select Tags to Monitor dialog box, shown in Figure 2-6, that 
lets you select which tags to monitor and configure how often to refresh 
monitor display. The Available Tags list box shows the tags that are no
displayed in the Tag Display Table. By default, the timeout is set to 
1.00 second. This controls how often the Tag Display Table is refreshed
default, no tag is selected to trigger a refresh of the Tag Display Table. Se
a tag to trigger a refresh of the Tag Display Table from the Trigger Tag Ri
Then, the Tag Display Table refreshes each time that tag is updated in 
database, or when the timeout interval elapses, whichever occurs first.
© National Instruments Corporation 2-11 BridgeVIEW Run-Time System Guide
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The Status Details dialog box, shown in Figure 2-5, displays a summary of 
the status for each tag in the system. For more detailed information ab
this dialog box, see Table 2-4, Tag Monitor Utility Field Descriptions. 

Figure 2-5.  Status Details Dialog Box

With the Select Tags to Monitor dialog box, shown in Figure 2-6, you can 
select which tags to monitor and configure how often to refresh the mon
display. For more detailed information about this dialog box, see Table 2-4, 
Tag Monitor Utility Field Descriptions. 

 

Figure 2-6.  Select Tags to Monitor Dialog Box
BridgeVIEW Run-Time System Guide 2-12 © National Instruments Corporation
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How Do You Access Online Help? 
The system developer might have included online help for your 
application software. Consult the documentation for your application
check with the system developer about the availability of 
application-specific online help. 

BridgeVIEW Run-Time System Online Reference is available online by 
selecting Help»Online Reference or by double-clicking on the 
bridge.hlp  file included with the BridgeVIEW Run-Time System 
package.
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This chapter explains tags, the Tag Configuration Editor, and how y
edit tags within the BridgeVIEW system. Before you can run a 
BridgeVIEW application, you must specify a tag configuration.

What Is a Tag?
A tag is a connection to a real-world I/O point. The BridgeVIEW 
system supports four types of tags: analog, discrete, string, and bit
array. You can define and configure tags with the Tag Configuratio
Editor. You can consider a tag to be any piece of data in the Engine.
BridgeVIEW system can log tag values and calculate alarms 
automatically, if configured accordingly.

A memory tag is not connected directly to an I/O point. For more 
information about memory tags, see the Connection section later in this 
chapter. 

Note: If you are a Run-Time System user, it is unlikely that you will create new
tags because you cannot modify your application. However, you might fin
it necessary to modify the properties of a tag.

The BridgeVIEW Engine manages the Real-Time Database (RTDB
which contains information about all the tags in the system. The Eng
handles the following tasks: 

• Communicates with device servers

• Scales tag values

• Tracks alarms and events associated with tags, system errors 
events

• Logs tag values, alarms, events and system messages to disk
Time System Guide
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What Is the Tag Configuration Editor?
The Tag Configuration Editor is a tool that assists you in configuring
the parameters of the BridgeVIEW Engine. The chief component of t
configuration is the definition of all tags in the system. Other 
components include Alarm and Event Logging, and Historical Loggin

Caution: Editing or deleting tags might cause your application software to functio
incorrectly. Contact the application developer before making any change
to your .scf  file.

To start the Configuration Editor, select Project»Tag»Configuration 
from the menu bar of an open VI. Figure 3-1, Tag Configuration Editor, 
shows the Tag Configuration Editor with tanks.scf  loaded.

Figure 3-1.  Tag Configuration Editor

The Tag Configuration Editor records all tag information and Engin
parameters and stores this information in a BridgeVIEW Configurati
File with the extension.scf  (SCADA Configuration File). The 
BridgeVIEW Engine reads this file to determine all of the paramete
for execution. With the Tag Configuration Editor, you can specify th
following:

• Tags used in the system 

• File paths for historical data and event logging 

!
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The .scf  file does not contain any information about the VIs in you
MMI. In fact, it is not specific to a single application. Multiple user 
applications can run concurrently as long as they use the same set
tags. When you launch the Tag Configuration Editor, the last 
opened.scf  file opens automatically. 

Note: Only one.scf  file can be loaded and running in the BridgeVIEW Engine 
at a time. 

If you edit a.scf  file while the Engine is running, when you select 
Save or Save As… a dialog box prompts you to confirm that you wan
the Engine to shut down and restart with the updated configuration 

Note: Communication between the BridgeVIEW Engine and any device serve
is stopped temporarily when the Engine shuts down and restarts.

How Do You Create, Edit, or Delete a Tag?
From the main panel of the Configuration Editor, press one of the 
following buttons: Create Analog Tag(s), Create Discrete Tag(s), 
Create String Tag(s), or Create Bit Array Tag(s). A separate window 
prompts you to define a new tag. The tag name must be unique with
given configuration (.scf ) file. Select Done on the pop-up window 
when you finish creating the new tag. The change is not written to d
until you select Save from the File menu.

To edit an existing tag, double-click on the tag name in the main scr
of the Tag Configuration Editor, or select the tag name and then pr
the Edit Tag button. To delete an existing tag, select the tag name in 
main panel of the Configuration Editor and select Delete Tag.

Note:  If you delete a tag, the tag and its configuration information are remove
completely from the .scf  file. Once you delete a tag, you lose the 
configuration information pertaining to the tag. You still can retrieve 
historical and event information about the tag, but information such as th
tag description, units, range, and alarm settings is lost.

How Do You Edit Multiple Tags Simultaneously?
Use File»Export to export the tag information to a spreadsheet file, e
the fields, and then use File»Import  to import the tag configuration 
information from the edited spreadsheet file. For more information, s
the section How Do You Use Spreadsheet Files for Tag Configuration? in 
this chapter. 
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How Do You Set Default Values for Tag Configuration Fields?
You can simplify the tag configuration process by defining default 
values for several fields. For example, you might want to set data o
event logging on by default, or have the log deadband set to a partic
value by default. You can set default values for tag parameters using
Set Tag Parameter Defaults dialog box, shown below. To access th
dialog box, select Configure»Tag Defaults…. 

The default values apply when creating a new tag, importing a tag fr
the server registry, or importing a tag from a spreadsheet. In the cas
spreadsheet, a value in the spreadsheet overrides the default value
the field. For more information about the individual fields, see the 
section How Do You Configure Tags? in this chapter. 

How Do You Use Spreadsheet Files for Tag Configuration?
With the Tag Configuration Editor, you can export tag configuration
information to spreadsheet files, and import tag configuration 
information from spreadsheet files. The files are tab-delimited text 
(.txt ) files.

Select File»Export to save the file as a tab-delimited .txt  file. When 
you select Export , a dialog box prompts you to select and order the 
fields you want in your spreadsheet file. If you intend to edit the 
BridgeVIEW Run-Time System Guide 3-4 © National Instruments Corporation
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spreadsheet file and then import the edited information back into th
Tag Configuration Editor, select the All >>  button to select all available
fields. For easy viewing and editing in the spreadsheet, press the 
Use Default Order button.

After you have edited the file, save it as a .txt  file. Then, from the Tag 
Configuration Editor, select File»Import  to import the information 
from the spreadsheet file. 

If you use spreadsheet files with the Tag Configuration Editor, it is ve
important that you understand the following points:

• If you do not choose all of the fields when exporting your data, y
will lose configuration information when you import it back to th
Tag Configuration Editor. 

• You might choose to export a subset of information, and then r
on tag default parameters when you import the data back in to 
Configuration Editor. However, each row in the spreadsheet file
must contain the tag name and data type fields, or the import 
mechanism cannot read it. 

• Some configuration parameters, such as Historical Logging 
Configuration and Event Configuration, are inherited from the 
currently open .scf  file when you import spreadsheet data.
© National Instruments Corporation 3-5 BridgeVIEW Run-Time System Guide
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Note: If the tag name and data type fields are missing, the File»Import  option 
does not work on the spreadsheet file. 

For detailed information about the tag attributes you can include in a
spreadsheet you import, see the How Do You Configure Tags? section in 
this chapter.

How Do You Configure Tags?
When you configure a tag with the Tag Configuration Editor, you defi
several attributes for the tag. You can consider these attributes 
segmented into four categories: connection, operations, scaling, an
alarms. Each of these categories is explained in detail later in this 
chapter. 

This chapter contains four tables that provide descriptions of the 
attributes for each of these categories, and indicates the data type
which each attribute applies. You can find each of these tables, list
below, in the Connection, Operations, Scaling, and Alarms sections, 
respectively, of this chapter. 

• Table 3-1, Connection Configuration Attributes

• Table 3-2, Operations Configuration Attributes

• Table 3-3, Scaling Configuration Attributes

• Table 3-5, Alarms Configuration Attributes

If you import tag configuration information from a spreadsheet, you
spreadsheet should follow the same format as indicated in the Attrib
column of each of the tables listed above. For more information ab
using spreadsheets, see the section How Do You Use Spreadsheet Files
for Tag Configuration? in this chapter. 

Data Type
Configuration of a tag varies slightly depending on the data type. T
following sections discuss the details of tag configuration for each d
type.
BridgeVIEW Run-Time System Guide 3-6 © National Instruments Corporation
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Analog Tags
An analog tag is a continuous value representation of a connection t
real-world I/O point or memory variable. This type of tag can vary 
continuously over a range of values within a signal range.

Use an analog tag when you want to express a continuous value (f
example, 0 to 100).

Discrete Tags
A discrete tag is a two-state (ON/OFF) value representation of a 
connection to a real-world I/O point or memory variable. This type o
tag can be either a 1 (TRUE) or a 0 (FALSE).

Use a discrete tag when you want to express a two-state (ON/OFF
value.

Bit Array Tags
A bit array tag is a multi-bit value representation of a connection to 
real-world I/O point or memory variable. This type of tag can be 
comprised of up to 32 discrete values.

Use a bit array tag when you have a multi-bit value in which each of 
bits represents a flag or single value that is turned on or off. The 
maximum length of a bit array tag is 32. 

String Tags
A string tag is an ASCII character representation of a connection to
real-world I/O point or memory variable.

Use a string tag when you have binary information or an ASCII valu
For instance, you might use a string tag to obtain values from a bar c
reader, or if you have data that does not fit into any other data type
© National Instruments Corporation 3-7 BridgeVIEW Run-Time System Guide
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Connection
You associate a tag with its real-world I/O point by assigning it a 
Server, Device, and Item in the Connection tab of the Tag 
Configuration dialog box, shown in Figure 3-2, Tag Connection Dialog 
Box. When you edit a tag, use the ring inputs to assign these value
the tag. BridgeVIEW cannot connect to a device server until you run 
configuration or registration utility for your device server. For more
information about device servers, see Chapter 7, Industrial Automation 
Device Servers.

Figure 3-2.  Tag Connection Dialog Box

The following table, Connection Configuration Attributes, provides 
descriptions of the connection attributes, and indicates the data type
which each attribute applies. For tag attribute information about the
other configuration categories, see Table 3-2, Operations Configuration 
Attributes, Table 3-3, Scaling Configuration Attributes, or Table 3-5, 
Alarms Configuration Attributes, in this chapter.
BridgeVIEW Run-Time System Guide 3-8 © National Instruments Corporation
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Table 3-1.     Connection Configuration Attributes

Attribute
Applies to 

Data Types
 

Description

 Tag Name all Determines the name of the tag you are configuring. Always re
to a tag by its name. Tag names are not case sensitive and c
include any combination of printable characters (including 
space) with the exception of “/” (forward slash) and “\” 
(backslash). 

Data Type all Determines the data type of the tag you are configuring. 
BridgeVIEW tags can be analog, discrete, bit array, or string.

Tag 
Description

all Provides a description of the tag. 

Group all Determines the group name to use for this tag. You can use 
groups to assist in alarm management and reporting and to h
organize tags in an application. 

Tag Access all Determines the access rights for a tag. Tags can have acces
rights of Memory, Input only, Output only, or Input/Output. 
Memory tags are not directly connected to real-world I/O point
You can use memory tags to monitor and control calculated 
values and enable historical trending and alarming on these 
values. Input only, Output only, and Input/Output tags are 
connected to real-world I/O points according to the Server, 
Device, and Item fields. 

Server all Determines the device server that manages the communicatio
the tag value. If the tag is a memory tag, this attribute is not us

Device all Determines the specific device used by the server for this tag. 
example, a PLC server might communicate with multiple PLC
The device field determines which PLC is used for this tag. If th
tag is a memory tag, this attribute is not used.
© National Instruments Corporation 3-9 BridgeVIEW Run-Time System Guide
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What Is a Memory Tag?
Memory tags are not connected directly to I/O points. They exist onl
in the BridgeVIEW RTDB. To configure a memory tag, set the Access 
Rights of a tag to Memory.

Note: If you are a Run-Time System user, it is unlikely that you will create new
tags because you cannot modify your application. However, you might fin
it necessary to modify the properties of a tag.

When Should You Use a Memory Tag?
Use memory tags when you want to perform alarm calculations, or 
historical data and event information on data that is either a 
software-generated value or a combination of values from different 
tag readings.

How Do You Import Items from the Server Registry? 
Use the Configuration Wizard to import items from the server regist
When you run the server configuration utilities for the servers on yo
system, you can define devices and items for the I/O points that th
servers monitor and control. You can import these items into the T
Configuration Editor automatically with the Configuration Wizard. 

The Configuration Wizard is useful particularly if you want the 
BridgeVIEW Engine to monitor a large number of the I/O points in yo
system. To invoke the Configuration Wizard, press the Configuration 
Wizard  button on the main screen of the Tag Configuration Editor. F
more information on server registry, see Chapter 7, Industrial 
Automation Device Servers.

Item all Determines the register, channel, or item on the device for thi
tag. This might be a PLC register, a data acquisition channel,
a DDE item, depending on the server used for this tag. If the t
is a memory tag, this field is not used.

Length string, 
bit array 

Determines the maximum number of bits in the bit array. The
length is between 1 and 32 for bit array tags. String tags can b
any length.

Table 3-1.     Connection Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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How Do You Connect a Tag to a DDE Server?
Although most BridgeVIEW servers are not based on Dynamic Dat
Exchange (DDE), you can connect a tag to any existing DDE Serve
Select DDE Server as your server in the connection tab of the Tag 
Configuration Editor to communicate with DDE servers. DDE Serve
have an Application Name, Topic, and Item. In BridgeVIEW, the 
device is set to appname|topic  (“|” = the “pipe” symbol) and the item 
is set to item . For example, to connect a tag to cell R1C1 (item) of 
spreadsheet sheet1  (topic) in Excel (application), set the tag fields to
the following:

Server: DDE Server

Device: Excel|sheet1

Item: R1C1

To specify a particular sheet ("sheet one" ) within an open Excel file 
(book1.xls ), set the device field to the following:

Device: Excel|[book1.xls]sheet1

How Do You Define a Group of Tags for Alarming?
While editing a tag, pull down the Group Ring. You can select an 
existing group or define a new group by selecting Enter New…. To 
create, edit, or delete group definitions, select Groups… from the 
Configure menu from the main Configuration Editor panel.

You can use groups to help define a subset of tags in the system. Gr
are helpful when you want to examine the alarm states for a subse
tags in the system.
© National Instruments Corporation 3-11 BridgeVIEW Run-Time System Guide
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Operations
The operations attributes include when to update the tag value in t
RTDB, whether to log data to a historical file, whether to log events
associated with the tag, and information about the initial value of the
at Engine startup. Figure 3-3, Tag Operations Dialog Box, shows the 
Operations Tab of the Analog Tag Configuration dialog box. With th
section of the dialog box, you can inform the BridgeVIEW Engine o
what to do with the data in the RTDB. 

Figure 3-3.  Tag Operations Dialog Box

The following table, Operations Configuration Attributes, provides 
descriptions of the operations attributes, and indicates the data type
which each attribute applies. For tag attribute information about the
other configuration categories, see Table 3-1, Connection Configuration 
Attributes, Table 3-3, Scaling Configuration Attributes, or Table 3-5, 
Alarms Configuration Attributes, in this chapter.
BridgeVIEW Run-Time System Guide 3-12 © National Instruments Corporation
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Table 3-2.     Operations Configuration Attributes

Attribute
Applies to 

Data Types
 

Description

Update 
Deadband

all Determines when the Real-Time Database (RTDB) updates t
value for this tag. It is used to improve system performance a
prevent unnecessary processing of tag values in the RTDB. T
field is expressed differently for analog, discrete, string, and b
array tags. For analog tags, Update Deadband is a percent of
scale. The database updates analog tags only when a new ta
value is different than the currently stored value by at least th
Update Deadband. Use 0% if you want each new value for the 
to be saved in the RTDB. For discrete, string, and bit array ta
Update Deadband is expressed as either Always or On Change.

Log Data analog, 
discrete,
bit array 

Determines whether a tag value is logged to historical files. 

Log Data 
Deadband

analog, 
discrete, 
bit array

Determines when tag values are logged to disk. It is used to 
improve system performance and prevent unnecessary loggin
data to disk. Like Update Deadband, the field is expressed 
differently for analog, discrete, and bit array tags. For analog 
tags, Update Deadband is a percent of full scale. The 
BridgeVIEW Engine writes new analog tag values to historica
files only when a new tag value is different than the last logge
value by at least the Log Data Deadband. Use 0% if you wan
each new value for the tag to be logged. For discrete and bit ar
tags, Update Deadband is expressed as either Always or On 
Change.

Log 
Resolution

analog Determines the resolution in engineering units for logging a ta
value in the Citadel Historical Database. Tag values are writte
to the database in a compressed format with the resolution 
specified by Log Resolution. Use 0.0  if you want the exact value 
written to the Citadel Historical Database. Notice that logging th
exact value requires more time and disk space. The default va
is 0.1 . 

Log/Print 
Events

all Determines whether events associated with the tag (for examp
changes in alarm state) are logged to event log files or printed
a line printer. 
© National Instruments Corporation 3-13 BridgeVIEW Run-Time System Guide
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What Is Deadband?
In process instrumentation, deadband is the range through which an 
input signal can vary without initiating an observable change in outp
signal. Deadband usually is expressed in percent of full scale. Altho
the term deadband generally applies only to analog tags, other tag t
have a limited type of deadband. A checkbox allows you to determ
if updates to the RTDB and historical data files should occur with a
new data from the device server or if the value has changed.

Note: The BridgeVIEW Engine performs historical logging and alarm 
management operations based on new values in the RTDB. If you set th
Update Deadband too high, the RTDB might not be updated. This could
result in inadequate historical logging or alarm management.

How Do You Use Deadband to Increase Engine 
Throughput?
The BridgeVIEW Engine uses Update Deadband and Log Deadban
values to eliminate unnecessary processing on minor data value 
changes. Deadband allows you to define a significant change. The
Engine ignores an operation if the change in data is not considered
significant. Deadband is expressed as percent of full scale. For exam
if the tag engineering range is 0 to 200 liters, a deadband of 5% is 
10 liters.

Set Initial 
Value

all Determines whether an initial value is used for this tag. If Set 
Initial Value is OFF for this tag, the tag value is marked as 
uninitialized until its value is updated. 

Initial Value all The initial value used for this tag when Set Initial Value is ON. 
the tag is an Output only or Input/Output tag, the BridgeVIEW
Engine sends the Initial Value to the server at Engine startup.
the tag is an Input only or Memory tag, the Initial Value is store
in the RTDB at startup. 

Table 3-2.     Operations Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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How Do You Configure a Tag to Log Its Data or 
Events?
While editing a tag, click on the Log Data or Log/Print Events 
checkbox. If you want to log historical data or events, the BridgeVIE
Engine must have these processes enabled. To turn them on, open
Engine Manager and manually turn on the processes with the pane
buttons, or, configure the Engine to turn on these processes 
automatically at startup. To configure the Engine in this way, pull dow
the Configure menu from the Tag Configuration Editor and select 
Historical…  or Events…. You also can enable these parameters 
programmatically with System VIs that enable event or historical da
logging.

How Do You Set Initial Tag Value at Startup?
While editing a tag, select the Set Initial Value checkbox. Then enter 
the initial value in the adjacent Initial Value  field.

Scaling
These attributes include what type of scaling to perform on a tag wh
communicating with the device server and the expected engineerin
range and units for the tag.

The following table, Scaling Configuration Attributes, provides 
descriptions of the scaling configuration attributes, and indicates th
data types to which each attribute applies. For tag attribute informat
about the other configuration categories, see Table 3-1, Connection 
Configuration Attributes, Table 3-2, Operations Configuration Attributes, 
or Table 3-5, Alarms Configuration Attributes, in this chapter.
© National Instruments Corporation 3-15 BridgeVIEW Run-Time System Guide
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Table 3-3.     Scaling Configuration Attributes

Attribute
Applies to 

Data Types
 

Description

Raw Full 
Scale

analog Determines the full scale (maximum) value used by the server 
a tag. 

Raw Zero 
Scale

analog Determines the zero scale (minimum) value used by the serv
for a tag.  

Eng Full 
Scale

analog Determines the full scale (maximum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Full Scale must be greater than Engineering Zer
Scale. 

Eng Zero 
Scale

analog Determines the zero scale (minimum) value used by the 
BridgeVIEW Engine and the user application for a tag. 
Engineering Zero Scale must be less than Engineering Full Sc

Units analog Determines the engineering units for a tag. Examples include
degrees Celsius, liters, and kilograms. 

Scaling analog, 
discrete, 
bit array

Determines the type of scaling algorithm to be used for a tag. T
scaling methods differ according to tag data type. You can 
configure analog tags to have linear or square root scaling. Y
can configure discrete tags to have invert scaling. You can 
configure bit array tags to have mask scaling. All tags can be
configured to have no scaling.

Coerce analog Determines whether to coerce data so that it is valid for the targ
If scaling to output, the value must be within the raw (device 
server) range. If scaling to input, the value must be within the
engineering (MMI) range. 
BridgeVIEW Run-Time System Guide 3-16 © National Instruments Corporation
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The next sections explain how to scale data. Often your application
needs BridgeVIEW to manipulate the raw data used in the device se
to put it in a form, called engineering units, suitable for the operato
The following sections describe the options for individual data type

Note: There is no scaling for string tags.

Analog Tags
You can define the raw range and engineering range for a tag to perf
simple conversions between the two ranges. The raw range, define
Raw Full Scale and Raw Zero Scale, refers to the values used by t
device server. Engineering range, defined by Engineering Full Sca
and Engineering Zero Scale, refers to the values used by the 
BridgeVIEW Engine and MMI. Pull down the Scaling ring and selec
Linear  to enable a linear (mx + b) conversion between raw and 
engineering ranges. Select Square Root to enable a square root 

Scaling Invert 
Mask

bit array Determines which bits are inverted for a bit array tag. Bits in th
mask that are 1 are inverted; bits that are 0 are not inverted. The 
default mask is 0, indicating that none of the bits are inverted. In
bit-wise logic terminology, the Engine performs an XOR with th
Invert Mask to produce the scaled value. 

Scaling Select 
Mask

bit array Determines which bits are used for the bit array tag. Bits in th
mask that are 1 have their values passed through to the RTDB
bits that are 0 are set to zero, regardless of the value received
from the server. In bit-wise logic terminology, the Engine 
performs an AND with the Select Mask to produce the scaled
value. 

Table 3-3.     Scaling Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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conversion between the raw and engineering ranges. Figure 3-4 shows 
the Scaling tab of the Analog Tag Configuration dialog box. 

Figure 3-4.  Analog Tag Scaling Dialog Box

The following examples describe linear and square root scaling. 

Example—Linear Scaling 
A device server returns a simple voltage from 0 to 5 volts. The volta
is related to a position sensor, and the real-world position is measu
in centimeters, with 0 volts mapped to 50 cm and 5 volts mapped t
100 cm.

Configure the tag to have raw range from zero (Raw Zero Scale) to 
(Raw Full Scale). Select Linear , and set the engineering range from 
50 (Eng Zero Scale) to 100 (Eng Full Scale).

Example—Square Root Scaling 
A flow meter measures the flow rate of a liquid using a differential 
pressure reading. The device server provides 4–20 mA readings. T
actual flow is measured in gallons per minutes (GPM). 4 mA 
corresponds to 0 GPM; 20 mA corresponds to 100 GPM.
BridgeVIEW Run-Time System Guide 3-18 © National Instruments Corporation
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Configure the tag to have raw range from 4 (Raw Zero Scale) 
to 20 (Raw Full Scale). Select Square Root Scaling and set the 
engineering range from 0 (Eng Zero Scale) to 100 (Eng Full Scale)

How Do You Assign Units to an Analog Tag?
Use the Engineering Unit  ring to assign units to a tag. If the desired un
is not in the list, select Enter New… and enter the desired unit. In the
previous example, you would be able to select units of GPM.

Discrete Tags
The only scaling available for discrete tags is invert scaling. Click t 
Invert Data checkbox, shown in Figure 3-5, Scaling for Discrete Tag 
Configuration, to advise the BridgeVIEW Engine to invert the discret
value when it communicates with the device server.

 

Figure 3-5.  Scaling for Discrete Tag Configuration
© National Instruments Corporation 3-19 BridgeVIEW Run-Time System Guide
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Bit Array Tags
Bit array tags can have invert and/or select mask scaling. You can 
the invert mask to determine which bits are inverted between the de
server and the BridgeVIEW Engine. You can use the select mask t
determine the bits you do not need. Figure 3-6, Scaling for Bit Array Tag 
Configuration, shows the Scaling tab of the Bit Array Tag Configuratio
dialog box, and Table 3-4, Bit Array Scaling Examples, provides 
examples of tags configured for bit array scaling.

Figure 3-6.  Scaling for Bit Array Tag Configuration

Table 3-4.     Bit Array Scaling Examples

Tag Name Length Raw Value Invert Mask Select Mask Scaled Value

Tag 1 8 0x0F 0x00 0xFF 0x0F

Tag 2 8 0x0F 0x33 0xFF 0x3C

Tag 3 8 0x0F 0x33 0x0F 0x0C

Tag 4 8 0x0F 0x00 0x33 0x30

Tag 5 8 0x0F 0x33 0x33 0x30

Tag 6 16 0x0FF0 0x000F 0x00FF 0x00FF
BridgeVIEW Run-Time System Guide 3-20 © National Instruments Corporation
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Alarms
These attributes include whether to enable alarms, under what 
circumstances a tag is in alarm, the priority level of an alarm, and h
alarms are acknowledged. Each alarm limit has a priority, ranging 
between 1 and 15. In BridgeVIEW, 15 is the highest priority and 1 is 
lowest.

There are two main types of alarms:

• Alarms based on status

• Alarms based on tag values

Configuration for alarms based on tag values is specific to data typ
Therefore, many alarm attributes apply to only a subset of the 
BridgeVIEW tag data types. For more information about how to acc
alarm information, build alarm summary displays, and retrieve 
historical events files, see Chapter 4, Alarms and Events.

The following table, Alarms Configuration Attributes, provides 
descriptions of the alarm attributes, and indicates the data types to
which each attribute applies. For tag attribute information about the
other configuration categories, see Table 3-1, Connection Configuration 
Attributes, Table 3-2, Operations Configuration Attributes, or Table 3-3, 
Scaling Configuration Attributes.

Table 3-5.     Alarms Configuration Attributes

Attribute
Applies to 

Data Types
 

Description

Alarms 
Enabled

all Determines whether alarms are enabled for a tag. 

Alarm 
Deadband

analog Determines the amount an analog tag value must diverge from
alarm limit before the alarm condition returns to normal. Alarm
Deadband is expressed in percent of full scale. 

Auto Ack all Determines how alarms can be acknowledged. If set to Auto A
the alarm is acknowledged automatically when the tag value 
returns to the NORMAL state. If set to User Must Ack, the alar
will remain unacknowledged until the user acknowledges it, 
regardless of the alarm state. 
© National Instruments Corporation 3-21 BridgeVIEW Run-Time System Guide
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Bad Status 
Enabled

all Determines whether to enable Bad Status alarms for the tag.

Bad Status 
Priority

all Determines the value (between 1 and 15) for the alarm priorit
for the Bad Status alarm, where 15 represents the highest prio

HI_HI 
Enabled

analog Determines whether to enable HI_HI alarms for a tag. 

HI_HI Limit analog Determines the value, in engineering units, that invokes a HI_
alarm condition. The tag alarm state remains HI_HI until the ta
value goes below the HI_HI alarm limit minus the alarm 
deadband. 

HI_HI 
Priority

analog Determines the value (between 1 and 15) for the alarm priorit
for the HI_HI alarm, where 15 represents the highest priority.

HI Enabled analog Determines whether to enable HI alarms for a tag. 

HI Limit analog Determines the value, in engineering units, that invokes a HI 
alarm condition. The tag alarm state remains HI until the tag 
value goes below the HI alarm limit minus the alarm deadban

HI Priority analog Determines the value (between 1 and 15) for the alarm priorit
for the HI alarm, where 15 represents the highest priority. 

LO Enabled analog Determines whether to enable LO alarms for the tag. 

LO Limit analog Determines the value, in engineering units, that invokes a LO
alarm condition. The tag alarm state remains LO until the tag 
value goes above the LO alarm limit plus the alarm deadband

LO Priority analog Determines the value (between 1 and 15) for the alarm priorit
for the LO alarm, where 15 represents the highest priority. 

LO_LO 
Enabled

analog Determines whether to enable LO_LO alarms for a tag. 

Table 3-5.     Alarms Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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LO_LO Limit analog Determines the value, in engineering units, that invokes a 
LO_LO alarm condition. The tag alarm state remains LO_LO 
until the tag value goes above the LO_LO alarm plus the alar
deadband. 

LO_LO 
Priority

analog Determines the value (between 1 and 15) for the alarm priorit
for the LO alarm, where 15 represents the highest priority. 

Discrete 
Enabled

discrete, 
bit array

Determines whether to enable tag value alarms for discrete a
bit array tags.

Alarm on discrete, 
bit array

Determines whether a discrete tag should be alarm on ON (hi
or OFF (low). Determines whether a bit array goes into alarm
all of its bits are in alarm or if any of its bits are in alarm. This 
field is used only if both Alarms Enabled and Discrete Enable
fields are set to TRUE.

Discrete 
Priority

discrete, 
bit array

Determines the value (between 1 and 15) for the alarm priorit
for the tag value alarm, where 15 represents the highest prior

Alarm Invert 
Mask

bit array Determines which bits are inverted before calculating the alar
state. Bits in the mask that are 1 are inverted; thus, cause an alarm
when low (0). Bits that are 0 are not inverted; thus, cause an 
alarm when high (1). The default mask is 0, indicating that no
of the bits are inverted. In bit-wise logic terminology, the Engin
performs an XOR with the Invert Mask to produce the alarm 
state. The Alarm Invert Mask is applied to the scaled value af
any relevant scaling masks have been applied. 

Alarm Select 
Mask

bit array Determines which bits are used for the bit array alarm 
calculation. Bits in the mask that are 1 are used in the alarm 
calculation; bits that are 0 will not cause an alarm, regardless o
their value. In bit-wise logic terminology, the Engine performs a
AND with the Select Mask to produce the alarm state. The Alar
Select Mask is applied to the scaled value after any relevant 
scaling masks have been applied. 

Table 3-5.     Alarms Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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How Do You Configure Alarms for a Tag?
While editing a tag, click the Enable Alarms checkbox. Alarms are 
generated depending on the value or state of a tag. The alarms bas
value vary with the tag data type. But for any tag, if the status is ba
Bad Status alarm is generated. By default, Bad Status Alarm is ena
and has the highest priority (15). You can change this selection from
Alarms tab of the Tag Configuration Editor, shown in Figure 3-7, 
Alarms for Analog Tag Configuration.

Alarm 
Message

discrete, 
bit array

Determines the string used to provide additional information 
about the meaning of an alarm condition. 

Tag Last 
Modified

all Indicates when the last edit to a tag occurred. 

Table 3-5.     Alarms Configuration Attributes (Continued)

Attribute
Applies to 

Data Types
 

Description
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Analog Tags
Analog tags have four alarm levels: HI_HI, HI, LO, and LO_LO. By
providing separate alarm levels, you can provide more information 
about the nature of the alarm condition.

Figure 3-7.  Alarms for Analog Tag Configuration

Alarms are calculated after scaling is performed. Alarm levels are 
expressed in engineering units.
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Discrete Tags
Discrete tags have one alarm state—either the tag is in alarm or it is
You can determine whether a tag is in alarm when it is ON (High) o
OFF (Low). Figure 3-8, Alarms for Discrete Tag Configuration, shows 
the Alarms tab of the Discrete Tag Configuration dialog box. 

Figure 3-8.  Alarms for Discrete Tag Configuration

Bit Array Tags
You can enable one of two types of alarms for bit array tags. Alarm
Any indicates that the overall tag is in alarm if any of the bits are in
alarm state. Alarm on All means that the overall tag is in alarm only
all of the bits are in alarm state. You can use the Invert Mask to 
determine the bits that should use alarm on low (OFF) rather than 
default alarm on high (ON). You can use the Select (AND) Mask to
determine the bits that should be considered for the alarm. If you h
bits in the Select Mask that are zero (OFF), these bits are not used
calculation of the tag alarm state. Figure 3-9, Alarms for Bit Array Tag 
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Configuration, shows the Alarms tab of the Bit Array Tag Configuratio
dialog box.

Figure 3-9.  Alarms for Bit Array Tag Configuration

String Tags
String tags have no alarm states based on tag value. They only sup
Bad Status alarms.

What Is Alarm Deadband on Analog Tags?
Alarm Deadband is a method commonly used to avoid repetitive ala
messages because of a tag value that hovers near the alarm limit. A
Deadband defines how much a tag value must change from the ala
limit before it is considered normal. For example, if a tag that represe
a temperature value hovers near an alarm limit of 40 degrees Cels
the tag might go in and out of alarm many times in a relatively shor
period of time. Table 3-6, Events with Alarm Deadband = 0.0%, shows 
examples of events with Alarm Deadband set to 0.0%.
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This type of situation clogs event files with redundant information a
can cause operators some frustration in having to acknowledge ala
constantly when the tag has not changed significantly. You can use
Alarm Deadband to alleviate this problem. 

For the tag to go into alarm, it must go above the exact Alarm Value
the above example, 40). However, to be considered normal again, 
must leave the Alarm Value by an amount greater than the Alarm 
Deadband. For example, if the range is 0 to 100 degrees Celsius, a
Alarm Deadband of 1.0% (one degree Celsius) eliminates unneces
events. Table 3-7, Events with Alarm Deadband = 1.0%, shows examples 
of events with Alarm Deadband set to 1.0%. 

Table 3-6.     Events with Alarm Deadband = 0.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 Yes  Normal

9:15:15 40.1 Yes  HI 

9:15:20 38.5 Yes  Normal

Table 3-7.     Events with Alarm Deadband = 1.0%

Time Value Event Alarm Type

9:15:05 40.1 Yes  HI 

9:15:10 39.9 No  HI

9:15:15 40.1 No  HI

9:15:20 38.5 Yes Normal
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How Do You Keep an Alarm Unacknowledged 
after the Alarm Returns to Normal?
While editing a tag, select the Alarm Acknowledgement Mode ring 
and choose either Auto Ack on Normal or User Must Ack.

Auto Ack on Normal 
With this option enabled, when a tag returns to normal state, the al
is automatically acknowledged. A message is logged to the event fil
event logging is turned on for the tag. By default, Auto Ack On Norm
is enabled.

User Must Ack
With this option enabled, an alarm remains unacknowledged until t
operator acknowledges the alarm.

How Do You Configure Other Engine Parameters?
There are other Engine parameters you can configure within the Ta
Configuration Editor. You can define your Historical Logging 
Configuration and Event Configuration by selecting 
Configure»Historical… or Events… through the BridgeVIEW Tag 
Configuration Editor dialog box, shown in Figure 3-1, Tag 
Configuration Editor. 

How Do You Turn on Historical and Event Logging at Startup?
To turn on historical and event logging at startup, select 
Configure»Historical… or Events… from the Tag Configuration 
Editor. Checkboxes in each dialog box turn on historical and event
logging at system startup. For more information, see Chapter 4, Alarms 
and Events, and Chapter 5, Historical Data Logging and Extraction.

How Do You Set the File Paths for Historical and Events Files?
From the main panel of the Tag Configuration Editor, select 
Configure»Historical… or Events…. The dialog box allows you to set
the path to the directories containing historical or events files.
© National Instruments Corporation 3-29 BridgeVIEW Run-Time System Guide
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How Do You Configure Shifts?
Shifts are valuable in configuring event logging. Shift start and stop
times determine how event files are segmented, and end of shift rep
can use these configuration files to determine process and line statis
From the main panel of the Tag Configuration Editor, select 
Configure»Events…. The panel has a shift display with which you ca
edit the configuration.

How Do You Configure Engine Parameters?
The BridgeVIEW Engine has several default settings for Engine 
parameters. However, you can override these defaults within the Bu
Configuration dialog box by selecting Configure»Engine from the Tag 
Configuration Editor. 

The BridgeVIEW Engine allocates certain amounts of memory for 
various queues. You can configure some of the parameters used b
Engine and Tags VIs to allocate memory for the Engine buffers 
yourself, but it is recommended that you use the default values. Th
parameters you can configure are listed in Table 3-8, Configurable 
Memory Allocation Parameters. 

Table 3-8.     Configurable Memory Allocation Parameters

Parameter Default Value

max # of lines to display on the system events 
display

20 

user error repeat rate 600 secs (10 minutes)

Event History Buffer size (# elements) 2000

Hist Log Queue size (# elements) 2000

Server Input Queue size (#elements)  2000

Server Input Queue binary size (bytes)   2000

Server Output Queue size (#elements)   2000

Server Output Queue binary size (bytes) 2000

Server Shutdown timeout (seconds) 30
BridgeVIEW Run-Time System Guide 3-30 © National Instruments Corporation
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Note: Although you can configure these parameters, it is highly recommended
that you maintain the default values.

How Do You Launch Server Configuration Utilities from 
the Tag Configuration Editor?

When you register a server in your system, BridgeVIEW registers t
location of its configuration utility, if it exists. You can access the 
server configuration utilities from the Servers menu of the Tag 
Configuration Editor.

Note: When you update the server registry while the Tag Configuration Editor i
running, select Servers»Refresh to prompt the Tag Configuration Editor to 
read the updated information. 
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This chapter introduces the basic concepts of alarms and events, a
explains how to view, acknowledge, and configure them within the 
BridgeVIEW system. 

What are Alarms and Events?
An alarm is an abnormal process condition pertaining to a tag. In 
BridgeVIEW, alarms are generated based on changes in a tag valu
status.

An event is something that happens within the BridgeVIEW system
Events can be divided into two groups: those that pertain to individ
tags and those that pertain to the overall BridgeVIEW system. 
Examples of tag events include a change of alarm state for a tag, o
user changing the value of a tag. Examples of system events inclu
user logging on, the Engine starting up, or historical logging being 
turned on. For more information about system events, see Chapter 2, 
BridgeVIEW Environment.

Alarm States
For analog tags, an alarm state can be of type HI_HI, HI, LO, or 
LO_LO. For all data types (analog, discrete, bit array, and string), if 
server returns a bad status, and you have enabled alarming on bad
status, the tag goes into Bad Status alarm. All data types except st
also support alarms based on tag value. If an analog tag exceeds a
preconfigured alarm limit, one of these alarms can occur. Discrete 
bit array tags are either not in alarm or in alarm.

Alarm Limit
An alarm limit is the numeric value that an analog tag must exceed
go into an alarm state.
Time System Guide
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Alarm Priority
An alarm priority indicates the severity of an alarm. Priorities range
from 1 (lowest) to 15 (highest). You can filter the alarms displayed 
your MMI by alarm priority. 

How Do You Configure Logging and Printing 
of Alarms and Events?

You can configure logging and printing options for Alarms and Even
through the Event Configuration dialog box, shown in Figure 4-1, Event 
Configuration Dialog Box. This configures the format of alarms and 
events that are written to .evt  files or printed. You can reach this dialog
box by choosing Project»Tag»Configuration, and then 
Configure»Events from the Tag Configuration Editor. 

Figure 4-1.  Event Configuration Dialog Box
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Refer to Table 4-1, Tag Configuration Editor Event Configuration 
Selections for a description of the general event configuration 
selections.

Table 4-1.     Tag Configuration Editor Event Configuration Selections

Selection Description

Event Directory Determines the path to the directory where the event files are stored on d

Store absolute 
path

Determines whether the absolute path is stored.

Start event 
logging on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins logging
events when the Engine launches.

Days to keep 
event files

Determines how many days worth of event files are kept on disk. Anythin
older than the number of days specified here is deleted automatically. 

Log Delimiter Determines the separator between parameters on a line. By default, it is th
character. This makes event files easy to import into a spreadsheet progr
Spreadsheet programs can handle other delimiters as well. 

Shift Display
(00:00  - 23:59 )

An array of numerics ranging between 00:00  and 23:59  hours to determine 
the length of the shift that events are logged in a file. At the end of the sh
a new event file is generated and written to. 

Start printing on 
system start-up

Determines whether the BridgeVIEW Engine automatically begins printing
events when the Engine launches.

Printer Determines the port to which your printer is connected.

Print Delimiter Determines the separator between different parameters on a line. By defa
it is a comma. 

Min Priority Determines the minimum priority an event must have before it is logged. 
Events with priorities below this configured number are not logged. The 
minimum value is 1.

Max Priority Determines the maximum priority an event can have to be logged. Events
with priorities above this configured number are not logged. The maximum
value is 15.
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There are various format options for logging and printing. The print
selections are a set of several parameters that determine the format o
data to be printed. Similarly, the log selections are a set of several 
parameters that determine the format of the data to be logged in an ev
file. These parameters are described in the following table. 

Table 4-2.     Event Configuration, Log, and Print Format Selections

Selection Description

Date Determines whether the date is logged or printed.

Date Format A menu ring that allows you to pick a format for the date to be printed. Th
selection is valid only if Date is selected. The menu items are: MM/DD/YYYY 
and DD/MM/YYYY.

Time Determines whether the time is logged or printed.

Time Format Determines the format for the time logged or printed. This selection is va
only if Time is selected. The menu items are: AM/PM and 24 HOUR.

Tag Name Determines whether the tag name is logged or printed.

Tag Name Field 
Length

Determines the maximum number of characters of which the tag name ca
comprised. This selection is valid only if Tag Name is checked.

Event Type Determines whether the event name is logged or printed.

Group Name Determines whether the group name is logged or printed.

Group Name Field 
Length

Determines the maximum number of characters of which the group name
be comprised. This selection is valid only if Group Name is checked. 

Alarm Value Determines whether the alarm value is logged or printed.

Alarm State Determines whether the alarm state is logged or printed.

Alarm Ack State Determines whether the alarm acknowledge state is logged or printed.

Alarm Priority Determines whether the alarm priority is logged or printed.

Alarm Limit Determines whether the alarm limit is logged or printed.

Operator Name Determines whether the name of the current operator is logged or printed
BridgeVIEW Run-Time System Guide 4-4 © National Instruments Corporation
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How Do You Log Alarms and Events?
Events are logged in ASCII files named in the format YYMMDDHHMM.evt 
using the timestamp of the first point to be logged. YY is the Year, MM is 
the Month, DD is the Day, HH is the Hour, MM is the Minute and .evt  is 
the extension for all event log files.

There are three steps you must complete to log alarms and events

1. You must configure your tags to have Log/Print Events enabled
You configure it on a per tag basis. To select event logging for 
single tag, go to the panel for configuring the tag. 

2. You must configure a path to a directory for the event (.evt ) files. 
To choose the path, select Configure»Events in the Tag 
Configuration Editor. 

3. You must turn on event logging for the BridgeVIEW Engine, 
according to one of the three techniques outlined below. 

There are two techniques for turning event data logging on or off. 

• You can configure event logging in the Tag Configuration Edito
To turn on event logging, use the pull-down menu for 
Configure»Events. Configure the path and set Start logging on 
system start-up to be TRUE. 

• The Engine Manager also has a button to turn event logging on
off. If you have Supervise or higher-level privileges, you can 
access this button.

Table 4-2, Event Configuration, Log, and Print Format Selections, 
provides a description of the event logging configuration selections

Operator Name 
Field Length

Determines the maximum number of characters of which the operator na
can be comprised. This selection is valid only if Operator Name is checked. 

Alarm Message Determines whether the alarm message is logged or printed.

Alarm Message 
Field Length

Determines the maximum number of characters of which the alarm mess
can be comprised. This selection is valid only if Alarm Message is checked.

Table 4-2.     Event Configuration, Log, and Print Format Selections (Continued)

Selection Description
© National Instruments Corporation 4-5 BridgeVIEW Run-Time System Guide
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How Do You Print Alarms and Events?
In BridgeVIEW, events are printed to a standard line printer through
parallel port. There are three steps you must complete to print alar
and events. 

1. You must configure your tags to have Log/Print Events enabled
You configure it on a per tag basis. To select event printing for
single tag, go to the panel for configuring the tag. 

2. You must configure a printer for event printing. To choose the 
printer, select Configure»Events in the Tag Configuration Editor. 

3. You must turn on event printing for the BridgeVIEW Engine, 
according to one of the three techniques outlined below. 

There are two techniques for turning event printing on or off. 

• You can configure event printing in the Tag Configuration Edito
To turn on printing, use the pull-down menu for Configure»Events. 
Configure the printer and set Start printing on system start-up to 
be TRUE. 

• The Engine Manager also has a button to turn event printing on
off. If you have Supervise or higher-level privileges, you can 
access this button.

Table 4-2, Event Configuration, Log, and Print Format Selections, 
provides a description of the printing configuration selections.

How Do You View Alarms and Events?
Event files are ASCII files and therefore can be read with any text 
editor. The default delimiter between the various parameters is a ta
character, which makes viewing the file in a spreadsheet program, s
as Excel, very convenient.
BridgeVIEW Run-Time System Guide 4-6 © National Instruments Corporation
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This chapter explains the concept of a trend, how to log and extrac
historical data, and how to use the Historical Trend Viewer (HTV), 
utility that displays historical data that has been logged to disk with
BridgeVIEW.

What Is a Trend?
A trend is a display of tag values against time. BridgeVIEW display
tag values with two types of trends: real-time trends and historical 
trends.

Real-Time Trend
A real-time trend is a display of tag values as they are collected in r
time over a relatively short period of time.

Historical Trend
A historical trend is a display of tag values that have been logged t
disk. This is usually over a relatively long period of time. You can vie
historical data by launching the HTV utility.

What Is Citadel?
Citadel is a high performance historical database. With Citadel, 
BridgeVIEW can log tags while continually servicing data queries.
BridgeVIEW also includes the Citadel ODBC driver that has specia
commands to perform data transforms, making it easy for you to 
retrieve, manipulate, and analyze historical data automatically from
outside the BridgeVIEW environment. For more information, see 
Appendix A, Citadel and Open Database Connectivity. 
n-Time System Guide
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How Do You Log Historical Data? 
There are three steps you must complete to log historical data. 

1. You must configure your tags to have historical logging enable
You configure it on a per tag basis. To select historical logging f
a single tag, go to the panel for configuring the tag. 

2. You must configure a path for the historical database. To choo
the path, select Configure»Historical in the Tag Configuration 
Editor. 

3. You must turn on historical logging for the BridgeVIEW Engine
according to one of the three techniques outlined below. 

There are two techniques for turning historical data logging on or o

• You can configure historical logging in the Tag Configuration 
Editor. To turn on logging, use the pull-down menu for 
Configure»Historical. Configure the path and set Start logging on 
system start-up to be TRUE. 

• The Engine Manager also has a button to turn historical data 
logging on or off. If you have Supervise or higher-level privilege
you can access this button.

When you log historical data for your application, there is a couplin
between your configuration (.scf ) file and the Citadel Historical 
Database. When you decide to archive these, take the .scf  file along 
with your historical files to the new location. Although you can retriev
historical data without the .scf file, you will not have the tag 
configuration information, such as engineering range and unit, unle
you archive the .scf file as well. 

Preferably, maintain the relative path between the .scf  file and the 
historical files in this new location. For example, if your .scf  file is in 
C:\ARCHIVE , keep your historical database in C:\ARCHIVE\DATA . 
BridgeVIEW Run-Time System Guide 5-2 © National Instruments Corporation
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How Do You Configure Historical Logging?
You can reach the Historical Logging Configuration dialog box by 
selecting Configure»Historical from the Tag Configuration Editor. 
Figure 5-1 shows the Historical Logging Configuration dialog box an
Table 5-1 lists parameters you can configure for historical logging.

Figure 5-1.  Historical Logging Configuration Dialog Box

Table 5-1.     Parameters You Can Configure for Historical Logging

Selection Description

Citadel Data Directory Path that determines the directory where historical data files are sto
on disk.

Store absolute path Determines whether the absolute path is stored.

Start logging on system 
start-up

Determines whether the BridgeVIEW Engine automatically begins 
logging historical data when the Engine launches.

Days to keep historical 
files

Determines how many days worth of historical log files to keep on dis
Anything older than the number of days configured here are deleted
automatically.

Maximum time between 
log records

Time, in seconds, that determines the logging rate for tags that vary
slowly.
© National Instruments Corporation 5-3 BridgeVIEW Run-Time System Guide



Chapter 5 Historical Data Logging and Extraction

n 
l 

l 
ht 

r 
How Do You Extract and View Data 
from Historical Log Files?

In addition to any historical trending tools included with the applicatio
software, you can use the Historical Trend Viewer to view historica
data that has been logged to disk. 

Historical Trend Viewer (HTV)
The HTVis a stand-alone utility that enables you to look at historica
data in your system. The HTV limits you to viewing no more than eig
tags at a time. 

Your application software might offer an alternative way to view 
historical data. For more information, consult the documentation fo
your application or the system developer.

To start the HTV, select Project»Historical Trend Viewer…. The HTV 
is shown in the following illustration. 
BridgeVIEW Run-Time System Guide 5-4 © National Instruments Corporation
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How Do You Select the Tags To Display?
Select File»Select Tags…, and the Select Tags dialog box appears, a
shown in Figure 5-2. With this dialog box, you can select either a .scf  
file or a directory of Citadel files. The default is to choose a .scf  file. 
The .scf  file you choose must point to a valid directory of Citadel file
If the BridgeVIEW Engine is running, the .scf  file being used by the 
BridgeVIEW Engine is displayed. 

Figure 5-2.  Select Tags Dialog Box

Note: You can look at data from only one Citadel database at a time.

Select the tags from the Available Tags list that you want to display
The HTV displays the tags in the order that they are listed in the Ta
to Display list.

Note: You can view configuration information about a tag by selecting it in the
Available Tags list, and clicking on the Tag Information  button.
© National Instruments Corporation 5-5 BridgeVIEW Run-Time System Guide
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How Do You Change the Time Axis?
You can change the time axis for a trend within the HTV manually,
by using Panning buttons. 

Panning Buttons
The Panning Buttons allow you to move backward and forward throu
the historical data in the trend. The buttons do not affect the timesp
of the trend. For example, if the trend displays data from 9:45 to 9:
on the same day, the timespan is ten minutes. Table 5-2 describes
Panning button functions.

Manual Changes
Alternatively, you can select the text at either end of the time axis a
change the data. You must enter the date in the correct format. If y
make an error, the input is ignored.

You can select and enter the time and date on the time (X) axis of 
historical trend on the HTV directly. However, the HTV responds 
immediately to any changes you make. If you want to make manua
edits to both the start and stop time on the time axis, you can selec
Viewer»Time & Date option. When you select this option, a dialog bo

Table 5-2.     Panning Button Functions

Button Name Description

|< Retrieve oldest data Displays the first available page of data.

<< Back one page Moves the display back by the current timespan.

< Back one-half page Moves the display back by half of the current timespan.

> Forward one-half page Moves the display forward by half of the current timespan.

>> Forward one page Moves the display forward by the current timespan.

>| Most recent data Displays the most recent available page of data.
BridgeVIEW Run-Time System Guide 5-6 © National Instruments Corporation
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appears, shown below, and you can enter the start and stop time o
data displayed in the trend.

How Do You Change the Timespan of Data 
Displayed?
The timespan indicator displays the amount of relative time between
start and end points of the time axis. To change the amount of time
between these points, you either can manually re-enter data in the 
or end point on the time axis, or pull down the ring for the timespan
indicator.

By default, the timespan ring contains the values 1:00, 10:00, 30:0
1:00:00, and 3:00:00. Select Other… in the timespan ring if you would 
like to enter a different amount of data to display.

How Do You View the Value of a Tag at a Specific 
Point in Time?
The Data Display table on the HTV, shown in Figure 5-2, shows the
tags displayed in the trend, the tag description, and the engineerin
units associated with the tag. The two rightmost columns show the
values of the tags at the two cursor locations in the trend. To move
cursors, grab their pointers at the bottom of the trend display. 

How Do You Change the Y Axis?
The HTV displays two Y axes at any time. Each Y axis displays the
color of the tag associated with it. Click on the Y axis to make it rota
through the tags displayed in the trend.

To change the range in the Y axis, select the text at the top or botto
the scale and type in the desired value. When you enter the value,
trend scale changes and the trend display updates. 
© National Instruments Corporation 5-7 BridgeVIEW Run-Time System Guide
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How Do You Change the Plot Colors and Style 
in the Trend?
Click on the Trend Legend. The pop-up window contains several 
options with which you can change the plot colors and styles used in
trend.

How Do You Zoom In on the Trend?
The HTV Trend  palette contains a Zoom tool that allows you to zoo
in on points of interest. The Zoom tool has five modes with which y
can zoom in on the trend: 

• Zoom by rectangle

• Zoom time scale

• Zoom Y scale

• Zoom in about one point

• Zoom out about one point

Undo Zoom resets the graph to its previous setting.

How Do You Export Data to a Spreadsheet?
From the HTV, select File»Export…. The HTV exports the information 
currently displayed in the trend to a tab-delimited file. A dialog box
prompts you for the name and location of the file to create. 

The HTV resamples data in periodic intervals so that all tags have 
same number of data points. The frequency defaults to a value 
according to the frequency of data in the historical files. If you want
override this value, enter the frequency you want in the dialog box.

How Do You Get Online Help for the HTV?
From the HTV, pull down the Help menu and select Show Help. 
A floating window is displayed that shows help information for all o
the objects on the HTV panel.
BridgeVIEW Run-Time System Guide 5-8 © National Instruments Corporation
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How Do You Set Tag, Time, and Color Preferences?
Set the preference for the HTV to remember settings on exit by 
selecting Viewer»Preferences. When you exit the HTV, the state of the
viewer is recorded.

Select the Remember settings on exit checkbox if you want to update 
your settings each time you exit the HTV. 
© National Instruments Corporation 5-9 BridgeVIEW Run-Time System Guide
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This chapter explains the BridgeVIEW Security System. BridgeVIEW 
environment security does not take effect until you configure it. 
Configuration consists of adding users and passwords.

Environment Security
Environment security is built into BridgeVIEW and determines acce
to certain BridgeVIEW utilities. For example, not all users should ha
the ability to configure the tags in the system or edit user accounts
BridgeVIEW uses seven levels of access privileges in its environme
Each set of privileges includes all of the privileges of those below i
These sets of privileges are defined in Table 6-1, Default Environment 
Access Levels and Privileges.

Table 6-1.     Default Environment Access Levels and Privileges

Privilege Level 
Name

Default Access 
Level Needed Environment Privileges

No Operator 0 Log in and change password.

View 25 Log in and change password.

Operate 50 Log in and change password.

Supervise 100 Enable and disable Event Logging, Historical Logging, and 
Printing; access to Historical Trend Viewer.

Diagnostics 150 Start and stop the BridgeVIEW Engine; configure paths for 
Event and Historical Logging in Tag Configuration Editor; 
access to the Tag Browser and Tag Monitor.

Development 200 Create and edit tags in the Tag Configuration Editor.

Administration 255 Create and edit user accounts and access levels; change th
configuration of BridgeVIEW environment access privileges
Time System Guide
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Access privileges to the BridgeVIEW environment are independent
access to objects in the operator interfaces that you develop for yo
application. 

How Do You Log In and Out?
To log in, choose Project»Security»Login. Type in your account name
and password. If you do not know your login name, or have forgott
your password, contact your BridgeVIEW administrator.

To log out, choose Project»Security»Logout.

How Do You Find Your Access Level?
After you have logged in, you can find your access level by choosin
Project»Security»Access Levels…. When you make this selection, the
Access Levels dialog box appears, as shown in Figure 6-1, Access Levels 
Dialog Box. 

Figure 6-1.  Access Levels Dialog Box

For more information about BridgeVIEW access levels and privilege
refer to Table 6-1, Default Environment Access Levels and Privileges.
BridgeVIEW Run-Time System Guide 6-2 © National Instruments Corporation
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How Do You Find Your Environment Access Privileges?
After you have logged in, you can find your access privileges by 
choosing Project»Security»Privileges…. When you make this 
selection, the Privileges dialog box appears, as shown in Figure 6-2. 

Figure 6-2.  Privileges Dialog Box

For more information about BridgeVIEW Access levels and privilege
refer to Table 6-1, Default Environment Access Levels and Privileges.

How Do You Change Your Password?
You must be logged in to change your password. Choose 
Project»Security»Change Password. 

Type in your old password, then your new password. Type in your n
password again to verify it.
© National Instruments Corporation 6-3 BridgeVIEW Run-Time System Guide
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How Do You Restrict Access to the BridgeVIEW Environment?
When you install BridgeVIEW, no user accounts exist, so all users h
Administration privileges. You must create user accounts for the 
normal security features to take effect. When you create user accou
you assign an access level to each account. 

When a user logs in, BridgeVIEW obtains the user access level an
determines the privileges for the user in the BridgeVIEW environme

How Do You Create and Modify User Accounts?
To create and modify user accounts, you must have Administration
privileges. To edit the list of user accounts, choose 
Project»Security»Edit User Accounts…, and the Edit User Accounts 
dialog box appears, as shown in Figure 6-3, Edit User Accounts 
Dialog Box.

Figure 6-3.  Edit User Accounts Dialog Box

Click the Add button to create a new user account. Type in a name
select an access level, and provide a password for the account then
the Add button. 
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After you have defined user accounts, you also can use this utility 
create more accounts, remove accounts, and change passwords a
access levels of existing accounts.

If you want to modify or delete several users at once, hold down th
<Shift> key on the keyboard when selecting users from the list.

Note: Once you have defined user accounts, you must have at least one acco
with Administration privileges (Access Level 255), unless you remove a
user accounts.

How Do You Modify the List of Available User Access Levels?
To edit the list of access levels, select Project»Security»Access Levels. 
You must have Administration privileges to edit the list of Access 
Levels. Click the Edit…  button next to the list of access levels. The Ed
Access Levels dialog box appears, in which you can add, remove, 
modify access levels. You also can edit access levels within the Ed
User Accounts dialog box by pressing the Edit Access Levels button, 
or choosing New… from the Access Level ring when creating or 
modifying a user account. In addition to the two permanent access
levels 0 and 255, you can assign up to 254 access levels for use in 
operator interface panels. If you remove an access level, users who 
been assigned that access level are demoted to the next lower acc
level.

Note: You can rename, but not remove, access levels 0 and 255. These are 
reserved for the No Operator and Administration privilege levels and mu
be present always.
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How Do You Modify Access Privileges in the BridgeVIEW Environment?
The seven levels of environment access privileges initially are assig
to the default user access levels in the system. As you add and mo
access levels, you might want to change which user access level h
certain privileges in the system. To change the access level require
gain a set of privileges, choose Project»Security»Privileges, and the 
Privileges dialog box appears, as shown in Figure 6-4. 

Figure 6-4.  Privileges Dialog Box

In the Privileges dialog box, you choose an access level required fo
user to gain certain privileges. To view the list of privilege levels an
the access levels needed for each, choose the Show Privilege Levels 
view. 

As access to the BridgeVIEW environment increases, the access le
needed to gain privileges also must increase. You cannot assign a
access level of 100 to the Development privilege level and an acce
level of 200 to the Diagnostics privilege level. However, you can ass
the same access level to both sets of privileges. 
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This chapter explains Industrial Automation (IA) device servers, how
install and configure a device server, and how to view that configurat
within BridgeVIEW. This chapter also describes how to use DDE 
servers with BridgeVIEW and how you can develop your own devic
servers.

BridgeVIEW includes the NI-DAQ Server, an Industrial Automation
device server that supports National Instruments data acquisition 
boards and SCXI, on the BridgeVIEW Development System CD. 
Additional device servers for other devices such as PLCs also are 
available for BridgeVIEW on the BridgeVIEW Device Servers CD. Fo
more information about BridgeVIEW device servers, inquire about t
Device Servers CD, available from National Instruments.

What Are Industrial Automation (IA) Device Servers?
An IA device server is any application that communicates with and 
manages I/O devices such as PLCs, remote I/O (Input/Output) devi
and data acquisition plug-in cards. IA device servers pass real-world
values to the BridgeVIEW Engine in real time. Each server monitors 
device items and encapsulates all device- and hardware-specific de
thereby establishing a device-independent I/O layer for BridgeVIEW

An item in BridgeVIEW is a channel or variable in a real-world devic
You must configure your IA device server to connect a tag to a 
real-world device and item. For more information about how to conn
a tag to a server, device, and item, see Chapter 3, Tag Configuration. 

The device servers also handle and report communications and de
errors to BridgeVIEW. There are different servers available for 
different device families and communication networks. 

Each IA device server is a stand-alone component that includes a 
configuration utility as well as a run-time application that 
communicates with the BridgeVIEW Engine. Device servers are no
built into the BridgeVIEW Engine itself. These servers are written to
Time System Guide
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standard client/server Applications Programming Interface (API) fo
communicating with the BridgeVIEW Engine and the Common 
Configuration Database.

When BridgeVIEW runs an application, it determines from the tag 
configuration (.scf ) file which servers are needed, and which device
and items are needed from those servers. BridgeVIEW launches e
server it needs, and notifies each one to monitor the specific devices
items of interest. Typically, servers monitor each input tag on a regu
basis, passing the values to the BridgeVIEW Engine when they chan
and updating each output tag when the BridgeVIEW MMI applicatio
writes that tag value. You define how a server monitors the devices 
items, how often it polls the devices, and other server-specific and 
device-specific parameters through each device server configuratio
utility.

How Do You Install and Configure a Device Server?
BridgeVIEW works with several device servers including the NI-DA
Server, the device servers available on the BridgeVIEW Device Serv
CD, and the simulation servers installed with BridgeVIEW.  In additio
you can use other servers available from companies other than Nati
Instruments.

To use a device server with BridgeVIEW, first you must install the 
device server and register it or run its configuration utility.  More 
specific information on installing and registering National Instrumen
servers follows later in this section. This information is written to th
Common Configuration Database, where BridgeVIEW obtains the 
server information. You configure a server, device, and item with th
server-specific Configuration Utility. Then, the Tag Configuration 
Editor can import server, device, and item information so you can 
create tags.

When you register a device server, its name appears in the list of ser
shown in the various Edit Tag screens of the Tag Configuration Edi
Once you configure your server, you can create a BridgeVIEW 
Configuration using that server. Depending on the server, different
information is written to the Common Configuration Database (CCD
when the server is registered.

The most simple servers register no more than their names and lau
paths. You can indicate devices and items by typing in the device a
BridgeVIEW Run-Time System Guide 7-2 © National Instruments Corporation
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item strings in the Edit Tag screen for each tag using that server. R
to your server documentation for the correct formats for these devi
and item strings.

The more complex servers register the devices to which they are 
connected and available items for those devices by name. These se
also can register the data type, directions, and engineering range a
units of the various items, if applicable. When you select these serv
in the Edit Tag screens of the BridgeVIEW Tag Configuration Edito
you see a list of available devices, and a list of items connected to 
device. For a selected device and item, the BridgeVIEW Tag 
Configuration Editor imports any available item engineering range a
unit information and also checks that the directions or access rights
an item are compatible with the access rights you have selected for
tag. Check your server documentation to find out if it registers devi
and item names and item parameters with BridgeVIEW. 

Installing and Configuring the NI-DAQ Server
The NI-DAQ Server is available on the BridgeVIEW Development 
System CD.  You can choose to install the NI-DAQ Server at the sa
time you install BridgeVIEW, or you can install the NI-DAQ Server a
a later time.  Select the NI-DAQ Server when you are prompted to 
install servers.

To install the NI-DAQ Server, follow these steps:

1. Insert the BridgeVIEW Development System CD in your CD-RO
drive.

Select Run… from the Start menu.

Then type 

X:\SERVERS\NI-DAQ\DISK1\SETUP

where X is the letter of your CD-ROM drive.

2. Please follow the instructions that appear on the screen.

After you install the NI-DAQ Server, you must run the NI-DAQ Serve
Configuration Utility to configure your DAQ system before you try t
use the NI-DAQ Server with BridgeVIEW. The NI-DAQ Server 
Configuration Utility also registers the NI-DAQ Server so you can u
it with BridgeVIEW.  See the NI-DAQ Server Online Help for more 
information on how to configure the NI-DAQ Server.
© National Instruments Corporation 7-3 BridgeVIEW Run-Time System Guide
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Installing and Configuring Device Servers from the BridgeVIEW Device 
Servers CD

The BridgeVIEW Device Servers CD contains servers for several PL
and remote I/O devices.  These device servers are DLL-based serv
using the Device Server Toolkit interface to BridgeVIEW.

To install the BridgeVIEW Device Servers from the BridgeVIEW 
Device Servers CD, follow these steps.

1. Insert the CD in your CD-ROM drive.

If you are running BridgeVIEW on Windows 95 or NT 4.0,

select Run… from the Start menu.

If you are running BridgeVIEW on Windows NT 3.51,

select File»Run… from the Program Manager.

Then type

X:\SETUP.EXE

where X is the letter of your CD-ROM drive.

2. Please follow the instructions that appear on the screen.

The Installer prompts you to select one or more servers to install.  It a
installs the Server Explorer, which all the device servers contained
the CD use for server configuration.  After you run the installer, you
must run the Server Explorer to configure the device-specific 
parameters of your industrial network before using the server with 
BridgeVIEW.  The Server Explorer also registers your server so you 
use it with BridgeVIEW.  Each server on-line help file documents 
configuration instructions specific to each server on the CD.  See t
on-line help files for your server for more information.

How Do You View BridgeVIEW Server Configuration?
The Tag Configuration Editor shows the list of available servers, an
any registered devices and items for the server in the various Edit 
screens. You also can use the Server Browser to view information ab
the servers registered with BridgeVIEW. Launch the Server Browser
selecting Projects»Server Tools»Server Browser… or by pressing the 
Server Browser… button on the Engine Manager Display. Use this 
utility to view the properties of the devices and items registered by e
server. For VI-based IA device servers, you can use this utility to 
display the server front panel while your application is running if yo
BridgeVIEW Run-Time System Guide 7-4 © National Instruments Corporation
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launch it from the Engine Manager. Typically, servers run with thei
front panel hidden. You can use the Server Browser to launch the 
server-specific configuration utility from within BridgeVIEW, if one is
available.

The Server Browser utility shows the server information stored in th
active Common Configuration Database (.ccdb ) file. You can control 
which CCDB is active from the Server Explorer utility. 

Use the Server Browser to unregister a server that you no longer w
to use. This keeps the server and related information from appearin
the Edit Tag screens. Notice that this invalidates any tags that use
server. Once you have unregistered a server, you can no longer con
to it from BridgeVIEW, and you must run its configuration utility agai
to register it with BridgeVIEW.

Figure 7-1.  Server Browser

The main screen of the Server Browser displays a list of servers 
available to BridgeVIEW in the Registered Servers list box if launch
from the Engine Manager. The symbol to the left of the server nam
indicates whether it is loaded and running. A black diamond indica
that the server is loaded and running. A white diamond indicates that
server is loaded but not running. No symbol indicates that the serve
not being used in the current BridgeVIEW Tag Configuration. The 
Server Browser also displays the path to the active CCDB in its title 

To view information registered for a specific server, double-click on t
server name in the Registered Servers list box, or press the View Server 
Devices… button. This invokes the View Server Device Information 
© National Instruments Corporation 7-5 BridgeVIEW Run-Time System Guide
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dialog box shown in Figure 7-2, View Server Device Information Dialog
Box.

To unregister a server that you no longer want to connect to your ta
press the Unregister Server button with the server of interest selecte
in the Registered Servers list box. This invokes a dialog box asking 
to confirm the operation.

Note: Unregistering a server means that BridgeVIEW can no longer access th
server, and any tag configured to use that server no longer has a valid 
configuration. Do this only if no tags are configured to use that server an
you no longer want to access it from the Tag Configuration Editor.

Registered Server Device and Item Parameters
Use the View Server Device Information dialog box to see a list of 
devices registered by a specific server, and for the selected device, 
a table of the registered items and item properties. The View Serve
Device Information VI is shown below.

Figure 7-2.  View Server Device Information Dialog Box

You can sort this table by item name, data type, or direction, by 
selecting which parameter you want to sort on in the Sort By: list. So
servers support adding devices or items for a device through the T
BridgeVIEW Run-Time System Guide 7-6 © National Instruments Corporation
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Configuration Editor. Type in the device string and/or item string to a
the device. 

If the selected server supports this ability, the  You can add devices and 
items to this server dynamically or You can add items to this device 
dynamically checkboxes are checked. If these boxes are not check
you only can select from pre-registered devices and items for this 
server.

If no devices are registered for a specific server, the Registered Dev
list box is empty and the No devices registered checkbox is checked. In 
this case, You can add devices and items to this server dynamically 
checkbox is checked, indicating that you must type the device and i
strings in the BridgeVIEW Tag Configuration Editor to choose a 
specific device and item. 

If no items are registered for a device, the Registered Items for Dev
table is empty, and the No items registered checkbox is checked. In this
case, the You can add items to this device dynamically checkbox is 
checked, indicating that you must type the device string in the Tag
Configuration Editor to choose a specific device.

Refer to your server-specific documentation to learn if your server 
registers devices and items, and if you can enter device and item str
in the Tag Configuration Editor to choose devices and items.

How Do You Use DDE Servers with BridgeVIEW?
BridgeVIEW can communicate with any server using Microsoft 
Dynamic Data Exchange (DDE) as its interface. A DDE server is 
treated as a simple server in which you type in a device and item st
to select a specific point. For DDE servers, you select DDE server fr
the Server List in the Tag Configuration Editor, and type in 
APPLICATION|TOPIC  for device, and ITEM for item. If you are using 
Network DDE to use a DDE server running on another machine, use
Network DDE name for the APPLICATION part of the name. Refer to 
your DDE server documentation for the correct name for 
APPLICATION, the list of available TOPICS and ITEMS for each topic.

Note: Unlike the servers written to the BridgeVIEW IA device server 
specification, off-the-shelf DDE servers do not register themselves with
BridgeVIEW. Therefore, BridgeVIEW cannot launch the DDE server 
automatically when it runs your MMI application. To use a DDE server, 
© National Instruments Corporation 7-7 BridgeVIEW Run-Time System Guide
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launch or run the DDE server before you run your BridgeVIEW 
application. BridgeVIEW will post system error messages if it cannot 
connect to the DDE server when it launches the BridgeVIEW Engine. 
Thereafter, it attempts to reconnect to the DDE server periodically. 
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This appendix describes the Citadel database and the Open Datab
Connectivity (ODBC) driver, and includes a table that lists data 
transform commands. 

The Citadel database only logs information to disk when the data 
changes. Users can query the database to extract information as if
were logged at regular intervals. The Citadel ODBC driver interpola
data as needed to return values at the requested intervals.

These data transforms allow you to calculate and retrieve complex
information directly from the database. This eliminates the need for
extracting raw data first, and then massaging it in another applicatio
come up with the needed information. Syntax for these transforms fu
conforms to SQL specifications. The following table lists the data 
transform commands.

Table A-1.     Data Transform Commands

Data Transform Command Description

Min{tag name} Returns the minimum for tag name 
across the interval.

Max{tag name} Returns the maximum for tag name 
across the interval.

Avg{tag name} Returns the average for tag name acros
the interval.

StDev{tag name} Returns the standard deviation for tag 
name across the interval.

Starts{tag name} Returns the number of starts (number o
transitions from OFF to ON) for tag 
name across the interval.
Time System Guide
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Because Citadel allows simultaneous real-time access by multiple 
applications, the ODBC Driver can retrieve data from the Citadel 
database even while BridgeVIEW is running. There is no need to 
interrupt data collection in order to query the database. In fact, the 
ODBC Driver allows multiple ODBC applications to perform SQL 
queries simultaneously.

Stops{Datapoint} Returns the number of stops (number o
transitions from ON to OFF) for 
Datapoint across the interval.

ETM{Datapoint} Returns the amount of time Datapoint 
was in the ON state across the interva

Qual{Datapoint} There might be gaps in the historical 
data threads in Citadel due to machine
shutdown or BridgeVIEW shutdown. 
Qual returns the ratio of time for which 
valid data exists for a datapoint across
the interval, to the length of the interval
itself. Thus if valid data exists for only 
one-half of the interval, Qual would 
return 0.5.

Table A-1.     Data Transform Commands (Continued)

Data Transform Command Description
BridgeVIEW Run-Time System Guide A-2 © National Instruments Corporation
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For your convenience, this appendix contains forms to help you gather the information nece
to help us solve your technical problems and a form you can use to comment on the produ
documentation.  When you contact us, we need the information on the Technical Support F
and the configuration form, if your manual contains one, about your system configuration t
answer your questions as quickly as possible.

National Instruments has technical assistance through electronic, fax, and telephone syste
quickly provide the information you need.  Our electronic services include a bulletin board 
service, an FTP site, a fax-on-demand system, and e-mail support.  If you have a hardwar
software problem, first try the electronic support systems.  If the information available on th
systems does not answer your questions, we offer fax and telephone support through our te
support centers, which are staffed by applications engineers.  

Electronic Services

National Instruments has BBS and FTP sites dedicated for 24-hour support with a collectio
files and documents to answer most common customer questions.  From these sites, you c
download the latest instrument drivers, updates, and example programs.  For recorded instru
on how to use the bulletin board and FTP services and for BBS automated information, ca
(512) 795-6990. You can access these services at:

United States:  (512) 794-5422
Up to 14,400 baud, 8 data bits, 1 stop bit, no parity

United Kingdom:  01635  551422
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

France:  01 48 65 15 59
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

To access our FTP site, log on to our Internet host, ftp.natinst.com , as  anonymous  and use 
your Internet address, such as joesmith@anywhere.com , as your password.  The support files
and documents are located in the /support  directories.

Bulletin Board Support

FTP Support
Time System Guide
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Fax-on-Demand is a 24-hour information retrieval system containing a library of documents
wide range of technical information.  You can access Fax-on-Demand from a touch-tone 
telephone at (512) 418-1111.

You can submit technical support questions to the applications engineering team through e
at the Internet address listed below.  Remember to include your name, address, and phone 
so we can contact you with solutions and suggestions. 

support@natinst.com

Telephone and Fax Support
National Instruments has branch offices all over the world.  Use the list below to find the tech
support number for your country.  If there is no National Instruments office in your country,
contact the source from which you purchased your software to obtain support.

Telephone  Fax
Australia 03 9879 5166 03 9879 6277
Austria 0662 45 79 90 0 0662 45 79 90 19
Belgium 02 757 00 20 02 757 03 11
Canada (Ontario) 905 785 0085 905 785 0086
Canada (Quebec) 514 694 8521 514 694 4399
Denmark 45 76 26 00 45 76 26 02
Finland 09 725 725 11 09 725 725 55
France 01 48 14 24 24 01 48 14 24 14
Germany 089 741 31 30 089 714 60 35
Hong Kong 2645 3186 2686 8505
Israel 03 5734815 03 5734816
Italy 02 413091 02 41309215
Japan 03 5472 2970 03 5472 2977
Korea 02 596 7456 02 596 7455
Mexico 5 520 2635 5 520 3282
Netherlands 0348 433466 0348 430673
Norway 32 84 84 00 32 84 86 00
Singapore 2265886 2265887
Spain 91 640 0085 91 640 0533
Sweden 08 730 49 70 08 730 43 70
Switzerland 056 200 51 51 056 200 51 55
Taiwan 02 377 1200 02 737 4644
U.K. 01635 523545 01635 523154

Fax-on-Demand Support

E-Mail Support (currently U.S. only)
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Technical Support* Form
Photocopy this form and update it each time you make changes to your software or hardwa
use the completed copy of this form as a reference for your current configuration.  Comple
this form accurately before contacting National Instruments for technical support helps our
applications engineers answer your questions more efficiently.

If you are using any National Instruments hardware or software products related to this pro
include the configuration forms from their user manuals.  Include additional pages if neces

Name ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Fax ( ___ )___________________ Phone ( ___ )____________________________________

Computer brand ________________ Model ________________ Processor_______________

Operating system (include version number) ________________________________________

Clock speed ______MHz   RAM _____MB  Display adapter _________________________

Mouse ___yes   ___no     Other adapters installed___________________________________

Hard disk capacity _____MB Brand __________________________________________

Instruments used _____________________________________________________________

___________________________________________________________________________

National Instruments hardware product model __________  Revision ___________________

Configuration _______________________________________________________________

National Instruments software product ____________________________ Version _________

Configuration _______________________________________________________________

The problem is: ______________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

List any error messages: ______________________________________________________

___________________________________________________________________________

___________________________________________________________________________

The following steps reproduce the problem:________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

* If you are a BridgeVIEW Run-Time System user and have questions about your application softwa
contact the system developer for technical support. 



 each 

this 

____

____

____

____

____

___

____

_____

____

____

___

____

____

____

____

____

____

____

____

____

_____

____

____
BridgeVIEW Run-Time System 
Hardware and Software Configuration Form
Record the settings and revisions of your hardware and software on the line to the right of
item. Complete a new copy of this form each time you revise your software or hardware 
configuration, and use this form as a reference for your current configuration. Completing 
form accurately before contacting National Instruments for technical support helps our 
applications engineers answer your questions more efficiently.

National Instruments Products
DAQ hardware ___________________________________________________________

Interrupt level of hardware __________________________________________________

DMA channels of hardware _________________________________________________

Base I/O address of hardware ________________________________________________

Programming choice _______________________________________________________

BridgeVIEW Run-Time System version ________________________________________

Other boards in system _____________________________________________________

Base I/O address of other boards ____________________________________________

DMA channels of other boards _______________________________________________

Interrupt level of other boards _______________________________________________

Other Products
Application Software Developer _______________________________________________

Computer make and model __________________________________________________

Microprocessor ___________________________________________________________

Clock frequency or speed ___________________________________________________

Type of video board installed ________________________________________________

Operating system version ___________________________________________________

Operating system mode ____________________________________________________

Programming language _____________________________________________________

Programming language version ______________________________________________

Other boards in system _____________________________________________________

Base I/O address of other boards ____________________________________________

DMA channels of other boards _______________________________________________

Interrupt level of other boards _______________________________________________



 

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____

____
Documentation Comment Form
National Instruments encourages you to comment on the documentation supplied with our
products. This information helps us provide quality products to meet your needs.

Title: BridgeVIEW™ Run-Time System Guide

Edition Date: June 1997

Part Number: 321635A-01

Please comment on the completeness, clarity, and organization of the manual.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

If you find errors in the manual, please record the page numbers and describe the errors.

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

___________________________________________________________________________

Thank you for your help.

Name _____________________________________________________________________

Title ______________________________________________________________________

Company ___________________________________________________________________

Address ____________________________________________________________________

___________________________________________________________________________

Phone (___ )__________________________  Fax (___ ) _____________________________

Mail to: Technical Publications Fax to: Technical Publications
National Instruments Corporation National Instruments Corporation
6504 Bridge Point Parkway (512) 794-5678
Austin, TX  78730-5039
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access level Determines which access privileges a user has for certain BridgeV
utilities. Access level values are between 0 and 255.

ACK (Acknowledge) The sequence action that indicates recognition of a new alarm.

alarm An abnormal process condition. In BridgeVIEW, an alarm occurs if
tag value goes out of its defined alarm limits or if a tag has bad sta

Alarm Summary A display of tags currently in alarm, or a display of tags previously
an unacknowledged alarm state that have returned to a normal sta

analog tag A continuous value representation of a connection to a real-world
I/O point or memory variable. This type of tag can vary continuousl
over a range of values within a signal range.

application software The application created using the BridgeVIEW Development Syst
and executed in the BridgeVIEW Run-Time System environment.

Prefix Meaning Value

m-

k-

M-

milli-

kilo-

mega-
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bit array tag A multibit value representation of a connection to a real-world I/O po
or memory variable. In BridgeVIEW, this type of tag can be compris
of up to 32 discrete values.

BridgeVIEW A program development application for real-time process monitorin
and control. BridgeVIEW uses the graphical development environm
called G.

BridgeVIEW Engine The heart of the BridgeVIEW system. It maintains the Real-Time 
Database of all tag values and alarm states. The BV Engine runs a
separate process, independent of your MMI application. 

BridgeVIEW An execution environment for applications created using the
Run-Time System BridgeVIEW Development System.

C

Citadel A database for storing historical tag values.

D

deadband In process instrumentation, the range through which an input signa
vary, upon reversal of direction, without initiating an observable chan
in output signal. Deadband is usually expressed in percent of rang
See log deadband and update deadband.

device An instrument or controller that is addressable as a single entity a
controls or monitors real-world I/O points. A device is often connect
to the host computer through some type of communication network
can be a plug-in device.

device server An application that communicates with and manages a peripheral
hardware device such as a Programmable Logic Control (PLC), rem
I/O device or plug-in device. Device servers pass tag values to the
BridgeVIEW Engine in real time.

discrete tag A two-state (on/off) value representation of a connection to a real-w
I/O point. In BridgeVIEW, this type of tag can be either a one (TRUE
or a zero (FALSE).
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Engine See BridgeVIEW Engine.

engineering units (EU) Terms of data measurement, as degrees Celsius, pounds, grams
so on.

error message An indication of a software or hardware malfunction, or an 
unacceptable data entry attempt.

event Something that happens to a tag in the BridgeVIEW system. Even
include tags going into or out of alarm state and the user setting a 
value. 

G

G The graphical programming language used to develop BridgeVIEW
applications.

group See tag group.

H

Help window Special window that displays the description of controls and indicat
The window also accesses the Online Reference.

historical trend A plot of data (values versus time) showing values that were previo
acquired in the system or logged to disk.

Historical Trend A utility that accesses historical data from the Citadel historical
Viewer (HTV) database.

I

input tag A tag that accepts Real-Time Database values from a device serv

Input/Output (I/O) tag A tag that accepts Real-Time Database values from a device serve
sends values to the server.

item A channel or variable in a real-world device that is monitored or 
controlled by a BridgeVIEW device server.
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LabVIEW Laboratory Virtual Instrument Engineering Workbench. A program 
development application used commonly for test and measuremen
purposes.

log deadband The range through which a tag value must change before it is logg
Citadel.

log resolution The smallest change in a tag value stored in the historical databas

M

Man Machine A graphical user interface for the user to interact with the
Interface (MMI) BridgeVIEW system.

MB Megabytes of memory.

O

operator The person who initiates and monitors the operation of a process.

output tag A tag that sends values to a device server whenever it is updated 
Real-Time Database.

P

PID See Proportional Integral Derivative Control.

PLC See Programmable Logic Control.

polling A method of sequentially observing each I/O point or user interface
control to determine if it is ready to receive data or request comput
action.

pop up To call up a special menu by clicking, usually on an object, with th
right mouse button.

pop-up menus Menus accessed by popping up, usually on an object. Menu optio
pertain to that object specifically.

positioning tool Tool used to move and resize objects. Resembles an arrow.
BridgeVIEW Run-Time System Guide G-4 © National Instruments Corporation



Glossary

n 

ons.
nal
e 

 a 

, 
nge 

int is 

 in 

and 

nts.

trol 

of 
re, or 
Programmable Logic A device with multiple inputs and outputs that contains a program
Control (PLC) you can alter. BridgeVIEW Device Servers establish communicatio

with PLCs.

Proportional Integral A combination of proportional, integral, and derivative control acti
Derivative (PID) Refers to a control method in which the controller output is proportio
Control to the error, its time history, and the rate at which it is changing. Th

error is the difference between the observed and desired values of
variable that is under control action.

R

range The region between the limits within which a quantity is measured
received, or transmitted expressed by stating the lower and upper ra
values.

Real-Time Database An in-memory snapshot of all tags in the system.
(RTDB)

real-time trend A plot of data (values versus time) that is updated as each new po
acquired in the Real-Time Database.

reentrant execution Mode in which calls to multiple instances of a subVI can execute
parallel with distinct and separate data storage.

representation Subtype of the numeric data type, of which there are signed and 
unsigned byte, word, and long integers, as well as single-, double-, 
extended-precision floating-point numbers, both real and complex.

resizing handles Angled handles on the corner of objects that indicate resizing poi

RTDB See Real-Time Database.

S

sampling period The time interval between observations in a periodic sampling con
system.

SCADA Supervisory Control and Data Acquisition.

sensor A device that produces a voltage or current output representative 
some physical property being measured, such as speed, temperatu
flow.
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string tag An ASCII character representation of a connection to a real-world
I/O point.

supervisory control Control in which the control loops operate independently subject 
intermittent corrective action.

system developer The creator of the application software to be executed in the 
BridgeVIEW Run-Time System.

system errors Errors that happen in the BridgeVIEW system, like a server going
down. System errors are displayed in a dialog box, on the Engine U
Interface, and also are logged in a syslog file.

system events Events that occur in the BridgeVIEW system, like an operator log
on or a utility starting up. System events are logged in a syslog file

T

tag A connection to a real-world I/O point or a memory variable. Tags c
be one of four data types: analog, binary, discrete, or string.

tag attributes Parameters pertaining to a tag, like its alarm, limits, or Engineerin
Units. Tag attributes are configured in the Tag Configuration Editor b
can be changed dynamically using the Tag Attributes VIs.

Tag Browser A utility to view the configuration parameters of a tag, as configure
the Tag Configuration Editor.

Tag Configuration A utility to configure various parameters of a tag, such as connect
Editor information, scaling, or logging.

tag group A list of tags primarily used for reporting and acknowledging alarms
tag can be associated with only one group. All tags belong to the gr
<ALL> by default.

Tag Monitor A utility to view the current value of a tag, along with its status and
alarm state.

tag status A variable that determines the validity of a tag value. A negative st
represents an error, a positive status represents a warning, and a s
of zero represents a good tag value.
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timestamp The exact time and date at which a tag value was sampled. Tag v
are stored with their timestamps in the RTDB.

trend A view of data over time. Trends can display real-time or historical
data.

U

update deadband The range through which a tag value must change before it is up
in the Real-Time Database.

user See operator.

user-defined constant Block diagram object that emits a value you set.

V

virtual instrument A program in the graphical programming language G; so-called bec
it models the appearance and function of a physical instrument.
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A
access levels and privileges. See environment 

security.
Alarm Deadband

events set to 0.0% (table), 3-28
events set to 1.0% (table), 3-28
overview, 3-27

alarms, 4-1 to 4-6
alarm limit, 4-1
alarm priority, 4-2
alarm states, 4-1
configuring logging and printing, 4-2 to 4-5
defining group of tags for alarming, 3-11
definition, 1-5, 4-1
logging, 4-5
printing, 4-6
tag configuration, 3-21 to 3-29

Alarm Deadband on analog tags, 
3-27 to 3-28

analog tags, 3-25
attributes (table), 3-21 to 3-24
Auto Ack on Normal option, 3-29
bit array tags, 3-26 to 3-27
configuration procedure, 3-24 to 3-27
discrete tags, 3-26
keeping alarm unacknowledged, 3-29
string tags, 3-27
User Must Ack option, 3-29

types of alarms, 3-21
viewing, 4-6

analog tags
alarm configuration, 3-25
assigning units to, 3-19
linear scaling example, 3-18
scaling, 3-17 to 3-19

Analog Tag Scaling dialog box, 3-18
square root scaling example, 3-18 to 3-19
tag configuration, 3-7

Auto Ack on Normal option, 3-29
Avg, data transformation command, A-1

B
bit array tags

alarm configuration, 3-26 to 3-27
scaling

examples (table), 3-19
illustration, 3-19

tag configuration, 3-7
BridgeVIEW engine

configuring, 3-30
configurable memory allocation 

parameters (table), 3-30
maintaining default parameters (note),

3-31
Engine Manager Display

field descriptions, 2-3 to 2-6
illustration, 2-3

launching from Project menu (table), 2-1
overview, 1-7
using deadband to increase 

throughput, 3-14
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BridgeVIEW environment. See environment 
for BridgeVIEW.

BridgeVIEW Run-Time System
getting started, 1-8 to 1-10
installing, 1-1 to 1-2, 1-8 to 1-9
overview and features

alarms, 1-5
events, 1-5
historical data logging and 

extraction, 1-5
overview and features, 1-3 to 1-6
security, 1-6
tag configuration, 1-3 to 1-4

purpose and use, 1-2 to 1-3
required system configuration, 1-1
system architecture, 1-6 to 1-8

BridgeVIEW engine, 1-7
industrial automation device servers, 

1-7 to 1-8
bulletin board support, B-1

C
Citadel historical database. See also historical 

data logging and extraction.
data transformation commands (table), 

A-1 to A-2
overview, 5-1
using with ODBC driver, A-2

color preference for HTV, setting, 5-9
configuration. See also tag configuration; Tag 

Configuration Editor.
BridgeVIEW startup, 1-9 to 1-10
historical data logging and extraction, 5-3
logging and printing of alarms and events, 

4-2 to 4-5
required system configuration, 1-1
server setup, 1-9
updating preference files, 1-9
viewing IA device server configuration, 

7-4 to 7-7

connection, 3-8 to 3-11
attributes (table), 3-9 to 3-10
connecting tag to DDE server, 3-11
defining group of tags for alarming, 3-11
importing items from server registry, 3-10
memory tags, 3-10
overview, 1-4
Tag Connection dialog box (figure), 3-8

customer communication, xiii, B-1 to B-2

D
data logging. See historical data logging and 

extraction.
data transformation commands (table), 

A-1 to A-2
data type, 3-6 to 3-7

overview, 1-4
tag configuration

analog tags, 3-7
bit array tags, 3-7
discrete tags, 3-7
string tags, 3-7

DDE servers
connecting tags to, 3-11
using with BridgeVIEW, 7-7 to 7-8

deadband
Alarm Deadband on analog tags, 

3-27 to 3-28
configuration, 3-14

effect on historical logging and alarm
management (note), 3-14

definition, 3-14
increasing engine throughput, 3-14
operations attributes (table)

Log Data Deadband, 3-13
Update Deadband, 3-13

device servers. See industrial automation 
device servers; servers.

discrete tags
alarm configuration, 3-26
scaling, 3-19
tag configuration, 3-7
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documentation
conventions used in manual, xii-xiii
documentation, xiii
organization of manual, xi-xii

Dynamic Data Exchange (DDE). See DDE 
servers.

E
electronic support services, B-1 to B-2
e-mail support, B-2
engine. See BridgeVIEW engine.
Engine Manager Display

field descriptions, 2-3 to 2-6
illustration, 2-3

environment for BridgeVIEW, 2-1 to 2-13
Engine Manager field descriptions, 

2-3 to 2-6
online help, 2-13
Project menu, 2-1 to 2-3
system errors and events, 2-6 to 2-7
Tag Browser utility, 2-7 to 2-9
Tag Monitor utility, 2-10 to 2-12

environment security, 6-1 to 6-6
access levels and privileges

default access levels and privileges 
(table), 6-1

finding, 6-3
finding access level, 6-2
modifying, 6-6
restricting access, 6-4

changing passwords, 6-3
creating and modifying user accounts, 

6-4 to 6-5
logging in and out, 6-2
modifying list of available user access 

levels, 6-5
overview, 1-6
Privileges dialog box (figure), 6-3
Project menu options for (table), 2-2

ETM, data transformation command, A-2

events
configuring

Event Configuration dialog box 
(figure), 4-2

log and print format selections 
(table), 4-4 to 4-5

Tag Configuration Editor event 
configuration selections (table), 4-3

configuring tags to log data 
or events, 3-15

definition, 1-3, 1-5, 4-1
logging, 4-5
Log/Print Events attribute (table), 3-13
printing, 4-6
system, 1-5
tags, 1-5
turning on event logging at startup, 3-29
viewing, 4-6

events files, setting path for, 3-29
extracting data from historical log files. See 

historical data logging and extraction.

F
fax and telephone support, B-2
Fax-on-Demand support, B-2
FTP support, B-1

H
help. See online help.
historical data logging and extraction, 

5-1 to 5-9. See also Citadel historical 
database.

configuring historical logging
configuration parameters (table), 5-3
Historical Logging Configuration 

dialog box (figure), 5-3
configuring tags to log data 

or events, 3-15
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Index
extracting and viewing data, 5-4 to 5-9
color preferences, 5-9
exporting data to spreadsheet, 5-8
Historical Trend Viewer (figure), 5-4
manual changes, 5-6
online help for HTV, 5-8
Panning Buttons, 5-6
plot colors and style in trend, 5-8
Select Tags dialog box (figure), 5-5
selecting tags to display, 5-5
tag preferences, 5-9
time axis, 5-5
time preferences, 5-9
timespan of displayed data, 5-7
viewing tag value at specific 

time, 5-7
Y axis, 5-7
zooming in on trends, 5-8

overview, 1-5
procedure for logging, 5-2
trends

definition, 5-1
historical trends, 5-1
real-time trends, 5-1

turning on at startup, 3-29
historical files, setting path for, 3-29
Historical Trend Viewer

illustration, 5-4
launching from Project menu (table), 2-1

I
Industrial Automation device servers, 

7-1 to 7-8. See also servers.
DDE servers, 3-11, 7-7 to 7-8
definition, 7-1
installing and configuring, 7-2 to 7-4

from BridgeVIEW Device Servers 
CD, 7-4

NI-DAQ server, 7-3
overview, 1-7 to 1-8, 7-1 to 7-2
servers supported, 7-1
unregistering servers, 7-5 to 7-6

View Server Device Information dialog 
box (figure), 7-6

viewing configuration, 7-4 to 7-7
registered server device and item 

parameters, 7-6 to 7-7
Server Browser, 7-4 to 7-6
Tag Configuration Editor, 7-4

installation
application software, 1-9
BridgeVIEW Run-Time System, 

1-1 to 1-2
device servers, 7-2 to 7-4

from BridgeVIEW Device Servers 
CD, 7-4

NI-DAQ server, 7-3
installation types (table), 1-8
required servers, 1-9
updating preference files, 1-9

item
definition, 7-1
importing items from server registry, 3-10
registered server device and item 

parameters, 7-6 to 7-7

L
linear scaling example, 3-18
logging. See also historical data logging and 

extraction.
alarms and events, 4-5

configuring logging and printing, 
4-2 to 4-5

configuring tags to log data or 
events, 3-15

log and print format selections 
(table), 4-4 to 4-5

Log/Print Events attribute 
(table), 3-13

turning on event logging at 
startup, 3-29

system errors and events, 2-7
logging in and out, 6-2
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M
manual. See documentation.
Max, data transformation command 

(table), A-1
memory tags

configuring, 3-10
definition, 3-10
when to use, 3-10

Min, data transformation command 
(table), A-1

N
NI-DAQ server, installing and 

configuring, 7-3

O
ODBC driver, A-2
online help

accessing, 2-13
Historical Trend Viewer, 5-8

Open Database Connectivity (ODBC) 
driver, A-2

operations, 3-12 to 3-15
attributes (table), 3-13 to 3-14
deadband for increasing engine 

throughput, 3-14
deadband setting, 3-14
logging data or events, 3-15
overview, 1-4
setting initial tag value at startup, 3-15
Tag Operations dialog box, 3-12

P
Panning Buttons, for viewing historical 

data, 5-6
passwords, changing, 6-3
plot color and style of trend, changing, 5-8
preference files, updating, 1-9
Project menu items (table), 2-1 to 2-3

Q
Qual data transformation command, A-2

R
Real-Time Database (RTDB)

definition, 1-7
Update Deadband attribute

description (table), 3-13
setting value to high (note), 3-14

S
scaling, 3-15 to 3-20

analog tags, 3-17 to 3-19
Analog Tag Scaling dialog box, 3-18
assigning units to, 3-19
linear scaling example, 3-18
square root scaling example, 

3-18 to 3-19
bit array tags, 3-20
configuration attributes (table), 

3-16 to 3-17
discrete tags, 3-19
overview, 1-4

security. See environment security.
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Server Browser
illustration, 2-6
launching

from Engine Manager (table), 2-4
from Project menu (table), 2-2

purpose and use, 2-5 to 2-6
viewing server configuration, 7-4 to 7-6

server registry
importing items from, 3-10
registered server device and item 

parameters, 7-6 to 7-7
servers. See also Industrial Automation device 

servers.
completing server setup, 1-9
DDE servers

connecting tags to, 3-11
using with BridgeVIEW, 7-7 to 7-8

definition of device server, 1-7
installation, 1-9
launching configuration utilities from Tag 

Configuration Editor, 3-31
setting up, 1-9

Set Tag Parameter Defaults dialog box, 3-4
shifts, configuring, 3-30
spreadsheet files, 3-4 to 3-6

exporting historical data to, 5-8
exporting tag configurations to, 3-4 to 3-5
importing tag configurations from, 3-5

square root scaling example, 3-18 to 3-19
Starts, data transformation command, A-1
StDev, data transformation command, A-1
Stops, data transformation command, A-2
string tags

lack of scaling for (note), 3-17
support of Bad Status alarms, 3-27
tag configuration, 3-7

system architecture, 1-6 to 1-7
system errors

definition, 2-6
logged to system log file, 2-7

System Event Display
illustration, 2-5
information displayed, 2-5
showing or hiding (table), 2-4

system events
definition, 2-6
logged to system log file, 2-7

system requirements for BridgeVIEW, 1-1

T
tag. See tags.
Tag Browser utility, 2-7 to 2-9

field descriptions (table), 2-8 to 2-9
illustration, 2-7
launching from Project menu (table), 2-2

tag configuration, 3-6 to 3-29. See also Tag 
Configuration Editor.

alarms, 3-21 to 3-29
alarm deadband on analog tags, 

3-27 to 3-28
analog tags, 3-25
attributes (table), 3-21 to 3-24
bit array tags, 3-26 to 3-27
configuration procedure, 

3-24 to 3-27
discrete tags, 3-26
keeping alarm 

unacknowledged, 3-29
string tags, 3-27
types of alarms, 3-21

connection, 3-8 to 3-11
attributes (table), 3-9 to 3-10
connecting tag to DDE server, 3-11
defining group of tags for 

alarming, 3-11
importing items from server 

registry, 3-10
memory tags, 3-10
overview, 1-4
Tag Connection dialog box 

(figure), 3-8
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creating tags, 3-3
data type, 3-6 to 3-7

analog tags, 3-7
bit array tags, 3-7
discrete tags, 3-7
overview, 1-4
string tags, 3-7

deleting tags, 3-3
editing or deleting tags (caution), 3-2
editing tags, 3-3
engine parameter configuration, 

3-30 to 3-31
exporting to and importing from 

spreadsheet files, 3-4 to 3-6
file paths for historical and events 

files, 3-29
historical and event logging 

at startup, 3-29
operations, 3-12 to 3-15

attributes (table), 3-13 to 3-14
deadband for increasing engine 

throughput, 3-14
deadband setting, 3-14
logging data or events, 3-15
overview, 1-4
setting initial tag value 

at startup, 3-15
Tag Operations dialog box, 3-12

overview, 1-3 to 1-4, 3-6
scaling, 3-15 to 3-20

analog tags, 3-17 to 3-19
assigning units to analog tags, 3-19
attributes (table), 3-16 to 3-17
bit array tags, 3-20
discrete tags, 3-19
overview, 1-4

shift configuration, 3-30

Tag Configuration Editor, 3-2 to 3-6
creating tags, 3-3
deleting tags, 3-3
editing multiple tags simultaneously, 3-3
editing tags, 3-3
illustration, 3-2
launching from Project menu (table), 2-3
launching server configuration 

utilities, 3-31
overview, 3-2 to 3-3
Set Tag Parameter Defaults dialog 

box, 3-4
setting default values for fields, 3-4
starting, 3-2
using spreadsheet files, 3-4 to 3-6
viewing server configuration, 7-4

Tag Monitor utility, 2-10 to 2-12
field descriptions (table), 2-11
illustration, 2-10
launching from Project menu (table), 2-3
Select Tags to Monitor dialog box 

(figure), 2-12
Status Details dialog box (figure), 2-12

Tag Operations dialog box, 3-12
tags

creating, 3-3
definition, 1-3
deleting (note), 3-3
editing, 3-3
editing or deleting tags (caution), 3-2
maintained by RTDB, 3-1
modifying properties (note), 3-1
setting preferences for HTV, 5-9
types of tags, 3-1

technical support, B-1 to B-2
telephone and fax support, B-2
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time
selecting specific point in time for tag 

value, 5-7
setting preferences for HTV, 5-9

time axis for trends, changing, 5-5
timespan of historical data, changing, 5-7
trends. See also historical data logging and 

extraction.
changing plot color and style, 5-8
definition, 5-1
historical trends, 5-1
real-time trends, 5-1
zooming in on, 5-8

U
user access levels. See also environment 

security.
modifying list of, 6-5

user accounts, modifying, 6-4
User Must Ack option, 3-29

V
viewing data from historical log files. See 

historical data logging and extraction.

Y
Y axis of HTV, changing, 5-7
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